Opened 13 years ago

Closed 12 years ago

#1999 closed Bug (duplicate)

rpc-authentication-required resets value on transmission-daemon restart

Reported by: andybee Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.52
Severity: Normal Keywords:
Cc:

Description

When setting rpc-authentication-required to 0 and saving settings.json and then starting the daemon the setting is correctly adhered to.

However, on restarting the daemon the settings.json file is rewritten to change the value to 1 so on restart authentication is required again.

Change History (6)

comment:1 Changed 13 years ago by charles

I can't reproduce this:

[charles@localhost daemon]$ ./transmission-daemon --version
Transmission 1.52 (8229)
[charles@localhost daemon]$ grep rpc-authentication-required $TRANSMISSION_HOME/settings.json 
    "rpc-authentication-required": 0, 
[charles@localhost daemon]$ ./transmission-daemon -f
[17:05:45.294] RPC Server: Adding address to whitelist: 127.0.0.1
[17:05:45.294] RPC Server: Serving RPC and Web requests on port 9091
[17:05:45.294] RPC Server: Whitelist enabled
[17:05:45.294] Transmission 1.52 (8229) started
[17:05:46.294] Port Forwarding (NAT-PMP): initnatpmp succeeded (0)
[17:05:46.294] Port Forwarding (NAT-PMP): sendpublicaddressrequest succeeded (2)
[17:05:48.329] Port Forwarding (UPnP): Found Internet Gateway Device "http://192.168.1.1:5431/uuid:0012-17c3-4e400200b4b4/WANIPConnection:1"
[17:05:48.329] Port Forwarding (UPnP): Local Address is "192.168.1.99"
[17:05:48.347] Port Forwarding (UPnP): Port forwarding through "http://192.168.1.1:5431/uuid:0012-17c3-4e400200b4b4/WANIPConnection:1", service "urn:schemas-upnp-org:service:WANIPConnection:1".  (local address: 192.168.1.99:51413)
[17:05:48.347] Port Forwarding (UPnP): Port forwarding successful!
[17:05:48.347] Port Forwarding: State changed from "Not forwarded" to "Forwarded"
[17:05:48.347] Port Forwarding: Opened port 51413 on :: to listen for incoming peer connections
[17:05:48.347] Port Forwarding: Opened port 51413 on 0.0.0.0 to listen for incoming peer connections
^C[17:05:52.486] Saved "/tmp/test/settings.json"
[17:05:52.862] Port Forwarding (UPnP): Stopping port forwarding through "http://192.168.1.1:5431/uuid:0012-17c3-4e400200b4b4/WANIPConnection:1", service "urn:schemas-upnp-org:service:WANIPConnection:1"
[17:05:52.862] Port Forwarding: State changed from "Forwarded" to "Starting"
[17:05:52.862] Port Forwarding: Stopped
[17:05:52.862] Port Forwarding: Closing port 51413 on ::
[17:05:52.863] Port Forwarding: Closing port 51413 on 0.0.0.0
Closing transmission session... done.
[charles@localhost daemon]$ grep rpc-authentication-required $TRANSMISSION_HOME/settings.json 
    "rpc-authentication-required": 0, 

comment:2 Changed 13 years ago by andybee

First thing I spotted is that 1.52 is released and I was still running 1.51 from the Ubuntu Jaunty repos, so I've upgraded but still am seeing the same results.

Here's what happens for me running it via init.d (I really hope this is not a simple n00b error as a result of the environment I'm running, but it's not behaving as I would expect it to?)

andy@server:~$ sudo /etc/init.d/transmission-daemon stop
 * Stopping bittorrent daemon transmission-daemon
   ...done.
andy@server:~$ transmission-daemon --version
Transmission 1.52 (8229)
andy@server:~$ sudo grep rpc-authentication-required /etc/transmission-daemon/settings.json
    "rpc-authentication-required": 0, 
andy@server:~$ sudo /etc/init.d/transmission-daemon start
 * Starting bittorrent daemon transmission-daemon
   ...done.
andy@server:~$ sudo /etc/init.d/transmission-daemon stop
 * Stopping bittorrent daemon transmission-daemon
   ...done.
andy@server:~$ sudo grep rpc-authentication-required /etc/transmission-daemon/settings.json
    "rpc-authentication-required": 1, 

Does the daemon apply some kind of rules that at least one particular type of authentication is required as I also have IP-based auth switched off?

comment:3 Changed 13 years ago by charles

I wonder if it's something to do with Ubuntu's scripts. You're not the first person to report this, but everyone who's mentioned it has been an Ubuntu user so far...

comment:4 Changed 12 years ago by John2095

Is it the '--auth' on Ubuntu Jaunty..?

john@lappy:/etc/transmission-daemon$ ps ax | grep transmission
18497 ?        S<sl   0:00 /usr/bin/transmission-daemon --auth --config-dir /var/lib/transmission-daemon/info
18750 pts/0    S<+    0:00 grep transmission
john@lappy:/etc/transmission-daemon$

http://trac.transmissionbt.com/ticket/1759#comment:1

daemon overwrites settings.json when it is called with --auth option 

comment:5 Changed 12 years ago by charles

Is there more information available on this ticket?

Right now it looks like either a Ubuntu script problem. I've confirmed that running transmission-daemon on its own works correctly.

comment:6 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #2119

Note: See TracTickets for help on using tickets.