Opened 12 years ago

Closed 12 years ago

#2003 closed Bug (fixed)

Web client reporting 100% before done

Reported by: barry Owned by: charles
Priority: Normal Milestone: 1.60
Component: Web Client Version: 1.51
Severity: Normal Keywords:
Cc:

Description

I noticed this while watching a big download. This bug is in web/javascript/torrent.js. Attached is a fix, diffed against r2810.

Attachments (3)

torrent.js.diff.r2810 (289 bytes) - added by barry 12 years ago.
web/javascript/torrent.js diff
26050563.png (91.7 KB) - added by charles 12 years ago.
example of the bug
torrent.js.r8280.diff (387 bytes) - added by barry 12 years ago.

Download all attachments as: .zip

Change History (12)

Changed 12 years ago by barry

web/javascript/torrent.js diff

comment:1 Changed 12 years ago by Gimp

Why on earth are you diff'ing to r2810? current revisions are past 8000....

comment:2 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.60
  • Owner changed from Gimp to charles
  • Status changed from new to assigned

applied to trunk for 1.60 in r8273

applied to 1.5x branch for a (unlikely) 1.53 release in r8272

comment:3 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Changed 12 years ago by charles

example of the bug

comment:4 Changed 12 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 12 years ago by charles

barry: this patch seems to have unintended behavior -- please see the attached screenshot. Could you please update the patch?

Changed 12 years ago by barry

comment:6 Changed 12 years ago by barry

patch is attached. sorry about 2810, i meant to type 8210. This patch is against 8280.

comment:7 Changed 12 years ago by livings124

barry: there was a patch put in, can you try a current nightly and report back?

comment:8 Changed 12 years ago by livings124

barry: ping

comment:9 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

according to godsyn this is fixed now.

Note: See TracTickets for help on using tickets.