Opened 12 years ago

Closed 11 years ago

#2025 closed Bug (worksforme)

unbelievable speeds

Reported by: pavolzetor Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.50
Severity: Normal Keywords:
Cc: pavol@…, asavartsov@…

Description

version: 1.51 (7963) Hallo, when I'm downloading files, I see very fast upload speed, my maximum of ISP is about 32 KB/s

problem is on screenshot

Attachments (1)

Obrazovka-Transmission.png (59.5 KB) - added by pavolzetor 12 years ago.

Download all attachments as: .zip

Change History (27)

Changed 12 years ago by pavolzetor

comment:1 Changed 12 years ago by pavolzetor

  • Cc pavol@… added

after restart program it's ok, but I think it's funny

comment:2 Changed 12 years ago by livings124

Can you replicate this with 1.60b?

comment:3 Changed 12 years ago by pavolzetor

I'm sorry, but I cannot replicate it in this version, it's rare

comment:4 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

None of the devs have seen this, and there's not enough information to even start trying to fix it (if it still exists).

comment:5 Changed 12 years ago by charles

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I don't know what triggers this, but I saw it briefly last night...

comment:6 Changed 12 years ago by charles

...and of course, I haven't seen it since. :/

comment:7 Changed 12 years ago by pavolzetor

It occurs when WiFi? connection is lagging

comment:8 Changed 12 years ago by David Munch

I saw this briefly during heavy IO on the harddrive, reaching 1.5 MB/sec on my 1 MBit upload connection, for a few seconds. Had Transmission running, and then started 5 applications (For the first time during the session, so nothing was cached).

Transmission 1.70, Mac OS X 10.5.7.

comment:9 Changed 12 years ago by charles

Ticket #2364 has been closed as a duplicate of this ticket.

comment:10 Changed 12 years ago by charles

Ticket #2482 has been closed as a duplicate of this ticket. I notice it has some new information: the speed reported in the peer inspector doesn't match the one in the main window:

The download speed in Transmission is keep growing since I start a torrent. Start from 0kb/s to 80Mb/s now, and It's still keep growing, whether it is connected with any peer or not. This is CRAZY.

The real download speed, according to peer inspector, is only 400kb/s. When I try to pause the torrent, and resume it. It just still showing the wrong speed 80mb/s and then keep growing.

comment:11 Changed 12 years ago by charles

bah, bitten by trac yet again.

The download speed in Transmission is keep growing since I start a torrent. Start from 0kb/s to 80Mb/s now, and It's still keep growing, whether it is connected with any peer or not. This is CRAZY.

The real download speed, according to peer inspector, is only 400kb/s. When I try to pause the torrent, and resume it. It just still showing the wrong speed 80mb/s and then keep growing.

comment:12 Changed 12 years ago by charles

http://trac.transmissionbt.com/attachment/ticket/2482/Picture%204.png shows the peer tab and the main window side-by-side.

comment:13 Changed 12 years ago by georgeeager

Ticket #2571 was closed as a duplicate of this one, but still:

Lately I've been reported from tracker administration about two announces sent to tracker, with upload speed reported as 2.73 GB/s и 1.36 GB/s (Gigabytes).

tracker admin supposed me cheating through modifying Transmission source code (never thought of that thou). The ban was lifted a week later.

Can I somehow prevent that situation? I do believe it's a bug or bad configuration (DHT and pex is on, can someone frame me somehow?).

I'll upgrade to 1.76 tomorrow, hope that helps.

comment:14 Changed 12 years ago by charles

The issue in the last comment isn't related to this ticket... I've un-duped #2571 so it can be looked at on its own merits.

comment:15 Changed 12 years ago by charles

  • Summary changed from unbelievable upload speed to unbelievable speeds

comment:16 Changed 12 years ago by charles

ticket #2909 has been closed as a duplicate of this ticket

comment:17 Changed 12 years ago by asavartsov

  • Cc asavartsov@… added
  • Version changed from 1.51 to 1.90

I've got such speeds today with 1.90. Progress/stats/ratio is OK, just funny speeds. I'm using transmission-daemon running on OpenBSD 4.6. I'm connecting to it via web interface.

comment:18 Changed 12 years ago by livings124

  • Version changed from 1.90 to 1.50

comment:19 Changed 12 years ago by glinsvad

I've noticed this in 1.92 (10363) but never with earlier versions. Additional info:

Both the total transfer rate and the rates for individual torrents sometimes become astronomical and keep increasing over time. I'm currently watching a 100 MB torrent download at an alleged (and increasing) rate of 67 MB/s which is clearly due to some form of bad arithmetic.

Limiting the download rate to say 5kb/s makes no difference in terms of the displayed rate, but of course still works as intended as far as I can tell.

This phenomenon is persistently occurring once Transmission has been running for a couple of hours but sometimes rectifies itself after a while with ludicrous speeds. The ETA and transferred file sizes are always correct, which must mean that the error lies in the time measurement and/or division. Another possibility is that the rates are simply printed wrong, but I find it hard to believe that such an obvious error would only be visible in some cases.

comment:20 Changed 11 years ago by glinsvad

An update:
I've been running System Monitor alongside Transmission for a while now and it seems that the onset of this problem correlates with a brief spike in the Network History in the order of GB/s. This might very well be a underlying bug in Ubuntu/Debian?, depending on how the transfer rates in Transmission are calculated. I'm running Ubunutu 8.10 with version 1.92-0ubuntu1.08.10.2 via this LaunchPad PPA.

comment:21 Changed 11 years ago by glinsvad

Another update:
It seems like this issue can be provoked to occur by changing the system clock. I don't know the exact underlying reason, but it's quite clear that scheduled runs of ntpdate don't go well together with Transmission.

comment:22 Changed 11 years ago by livings124

glinsvad: That is a known issue and one that won't be fixed. Pretty much all apps behave like that when times are changed. The issue we're concerned about is the speeds reported when this is not done.

comment:23 Changed 11 years ago by livings124

#3124 is a duplicate of this.

comment:24 Changed 11 years ago by charles

I haven't seen this behavior in at least six months. Is this still biting anyone else?

comment:25 Changed 11 years ago by David Munch

I haven't seen it lately.

comment:26 Changed 11 years ago by charles

  • Resolution set to worksforme
  • Status changed from reopened to closed

I'm going to close this for now since it doesn't seem to be happening anymore. If someone reading this is able to trigger it, please feel free to reopen this ticket. Thanks

Note: See TracTickets for help on using tickets.