Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2033 closed Bug (worksforme)

Setting high prio results in throttling to zero

Reported by: m1b Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.60+
Severity: Normal Keywords:
Cc: m1b

Description

Given two active seeding torrents:

T1: 1 seeder (me), 1 leecher, prio at normal
T2: Many seeders, many leechers, prio at low

In this state, T2 gets the lion's share of the (capped) upstream, T1 gets a pretty consistent 10%. This is reasonable (though somewhat nonintuitive) behavior.

If I switch T1 to high prio, its bandwidth use drops to 0. Switch back to normal and it goes right back to 10% of cap. I can switch back and forth at length and the behavior persists.

I would expect with two active torrents, one low and one high, that the high one would get all the bandwidth instead of being throttled down to zero.

First observed in nightlies running up to 1.60; still present in 1.60+ 8345

Change History (5)

comment:1 Changed 12 years ago by m1b

The T1 swarm has just changed population to 3 seeders and 2 leechers; changing its prio to high in 8345 now results in it getting 100% of the capped bandwidth. Switching it back to normal results in it reproducibly using 20-30% of bandwidth.

comment:2 Changed 12 years ago by m1b

Another update: the correlation seems to be with the number of peers connected in T1 rather than the swarm size. If there is only 1 connected peer (there are 2 in the swarm according to the tracker), high prio will throttle bandwidth to 0, whereas normal provides the abovementioned 10%.

comment:3 Changed 12 years ago by charles

I can't confirm this?

comment:4 Changed 12 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

m1b: this is working for me. do you have anymore information that might be useful about this?

comment:5 Changed 12 years ago by m1b

  • Cc m1b added

Sorry -- not at the moment. I can try reproducing again next time I have a with me-as-seeder and only a single 1 leecher. As comment 2 said above, the issue seems limited to the combination of 1 leecher + high prio. More as it happens...

Note: See TracTickets for help on using tickets.