Opened 12 years ago

Closed 12 years ago

#2052 closed Bug (fixed)

"Warning: Unresponsive Script" in Web GUI

Reported by: nveeser Owned by: charles
Priority: Normal Milestone: 1.70
Component: Web Client Version: 1.60+
Severity: Normal Keywords:
Cc: wearearobot@…

Description

Just upgraded from 1.51 to 1.60. Running the Web client with OS X 10.5.6, Firefox 3.0.10.

Initial load of just about any page results in the javascript hanging. Firefox will eventually time out the script with the above error message. It reports the script as the following:

Script: http://<host>:8080transmission/web/javascript/jquery/jquery.min.js:12

Change History (11)

comment:1 follow-up: Changed 12 years ago by closer

I have reproduce that problem when I have add some *.torrent files contain many internal files (~2000). Therefore web client do some large (~98kb) AJAX queries to /rpc and JQuery can't process returned JSON quickly.

Can you increase performance for *.torrent files which contain a lot of internal files? Can you increase priority because that bug is block my work with Transmission?

OS: Fedora 11 Beta, Firefox 3.5 Beta 4, Transmission 1.61 (8385)

comment:2 in reply to: ↑ 1 ; follow-up: Changed 12 years ago by charles

Replying to closer:

Can you increase priority because that bug is block my work with Transmission?

Surely every bug is filed because it blocks someone's work? :)

comment:3 in reply to: ↑ 2 Changed 12 years ago by closer

Replying to charles:

Surely every bug is filed because it blocks someone's work? :)

I try to describe my situation:

I have home server that I use as torrent and VMWare server. Now I use w2k3 as host system and uTorrent, but I want to migrate to Ubuntu. The VMWare Server works under Ubuntu, but uTorrent doesn't work (also I don't want to use Wine). Because I want to move ~300 torrent files from uTorrent to Transmission.

Before migration I have checked Transmission Web Client on my home comp with Fedora and that problem has appeared. That problem is very serious for me and I can't start migration to Ubuntu thereby. That bug blocks my migration therefore I am waiting for fixing that bug now or will try to find an alternative to WebUI :)

comment:4 Changed 12 years ago by charles

The Qt Client is still in its very early stages, but I've used it to connect to a daemon running thousands of torrents with less than 5% CPU load. You might want to give it a try, since nobody knows when the Web Client rewrite will be ready.

comment:5 in reply to: ↑ description Changed 12 years ago by jimsantora

  • Cc wearearobot@… added
  • Version changed from 1.60 to 1.60+

Replying to nveeser: I'm seeing the same issue after upgrading to 1.61-beta1 using the ubuntu ppa on launchpad. I also tried the latest nightly build (1.70-0ubuntu0~intrepid0~svn8486) and the problem persists.

I've recreated this with Firefox 3.5b4 on OSX 10.5.7. On the same system, Safari 4 beta (build 5528.17) works flawlessly without any errors or slowdown when loading.

comment:6 follow-up: Changed 12 years ago by kjg

as of r8490 I've cut this down by over 50% here are my before and after numbers (generated by using Firebug's profiler)

Orginal     | time (ms)  | function calls
------------|-------------------------
1     file  |     3.072  |      189
13    files |    36.332  |     2340
8289  files | 31766.946  |  1492020

r8490       | time (ms)  | function calls
--------------------------------------
1     file  |     1.264  |      75
13    files |    12.237  |     858
8289  files | 11193.279  |  547074

comment:7 Changed 12 years ago by charles

r8494 removes about 9% of the functions called during the initial CPU spike when loading the Web UI.

Loading the Web UI with 44 torrents

Revision   | time (ms)         | function calls
-----------+-------------------+-------------------
r8491      | 1.505             | 109,927
r8492      | 1.409             |  99,269

Profile of the remaining calls in r8492: http://transmission.pastebay.com/17509

comment:8 in reply to: ↑ 6 Changed 12 years ago by kjg

r8493 cuts down file initialization by about another 50% for a total of around 80% faster since r8489

Files      | time (ms)         | function calls
-----------+-------------------+-------------------
    1      |      .734         |      46
   13      |     6.569         |     481
 8289      |  4409.4           |  306693

comment:9 Changed 12 years ago by charles

r8494 removes about 9% of the functions called during the initial CPU spike when loading the Web UI.

Loading the Web UI with 44 torrents when the inspector is visible

Revision   | time (ms)         | function calls
-----------+-------------------+-------------------
r8492      | 3263.78ms         | 103,206
r8493      | 2921.211ms        |  99,267
r8494      | 2646.305ms        |  82,273

Profile of the remaining calls in r8492: http://transmission.pastebay.com/17509

comment:10 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.70
  • Owner changed from Gimp to charles
  • Status changed from new to assigned

Mu ha ha!

Loading the Web UI with 44 torrents when the inspector is visible

Revision   | time (ms)         | function calls
-----------+-------------------+-------------------
r8492      | 3263.78ms         | 103,206
r8493      | 2921.211ms        |  99,267
r8494      | 2646.305ms        |  82,273
r8500      |  446.653ms        |  12,065

comment:11 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

In r8505 I'm able to load about 375 torrents in 2311.9 ms.

That's 8x as much data, in less the time, of r8492.

Note: See TracTickets for help on using tickets.