Opened 12 years ago

Closed 12 years ago

#2060 closed Bug (duplicate)

transmission-daemon not remember session

Reported by: progserega Owned by:
Priority: High Milestone: None Set
Component: Daemon Version: 1.60
Severity: Major Keywords:
Cc:

Description

Steps to reproduce:

  1. Start transmission-daemon under user rights: su -c "trunsmission-daemon" user_name
  2. start (connect to localhost session) qt-gui or web-interface for adding seeding torrents.

At this step transmission daemon start verification data of all torrents, and then start seeding. All works properly.

  1. Close web-client or qtr, start it again - torrents continue seeding - all work properly.
  2. Say system to reboot or poweroff.
  3. After reboot transmission-daemon starts, but have no seeding torrents. Torrent files stay in directory, where torrent-daemon automatic get torrents for adding, but all list "seeding", "all", "active" - is empty. Moreover - port to listing torrent connection - not was remembering.

I'm sink, that this problem in code of "save session" by TERM-signal. I try send TERM-signal to transmission-daemon, but it stay work and not exit. If sent KILL-signal to transmission-daemon - it exit, but not remember any changes and any added torrents. On reboot, system send TERM, but transmission-daemon not stop and not save session, and then system send KILL - transmission daemon exit and not save session data.

PS: distrib is gentoo

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #2119.

Note: See TracTickets for help on using tickets.