Opened 12 years ago

Closed 12 years ago

#2064 closed Bug (invalid)

Main window moves down when using systray icon to hide/show it.

Reported by: kklimonda Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 1.60
Severity: Minor Keywords:
Cc:

Description

Hey,

Another bug from launchpad: https://bugs.launchpad.net/bugs/343436

When you use systray icon to hide/show transmission ui it "travels" down - i.e. every two cycles window moves down a bit until it hits bottom of the screen. It seems to be related to compiz as I can't reproduce it using metacity but on the other hand transmission is the only application that have this problem.

Attachments (1)

coord.diff (837 bytes) - added by charles 12 years ago.
add debug messages when hiding and presenting Transmission's main window in the gtk client

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by charles

add debug messages when hiding and presenting Transmission's main window in the gtk client

comment:1 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Using the debugging message patch attached above, I get this printed to my terminal when I click on the tray icon again and again to repeatedly show and hide Transmission's main window:

** Message: saving window location as x 0, y 25
** Message: setting window location to x 0, y 25
** Message: saving window location as x 0, y 25
** Message: setting window location to x 0, y 25
** Message: saving window location as x 0, y 25
** Message: setting window location to x 0, y 25
** Message: saving window location as x 0, y 25
** Message: setting window location to x 0, y 25
** Message: saving window location as x 0, y 25

Transmission uses gtk_window_get_position() to get the x,y coordinates, and then gtk_window_move() to reuse those x,y coordinates. This seems to be correct behavior, so I think this is a compiz problem rather than a Transmission one.

Note: See TracTickets for help on using tickets.