Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2068 closed Bug (worksforme)

Cannot limit speeds to 0 in speed limit mode.

Reported by: erudite Owned by:
Priority: Low Milestone: None Set
Component: Transmission Version: 1.60+
Severity: Minor Keywords:
Cc:

Description

You can limit the speed to 1 KB/s but not 0.

When you set the speed to 0 it just runs as if there is no limit.

Attachments (1)

speed-limit-mode.png (108.4 KB) - added by charles 12 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by charles

I can't reproduce this problem, so maybe I'm not following your report right. Here's what I did:

  1. started downloading a torrent, with no global nor per-torrent limits. (result: transmission was downloading the torrent at about 400 KB/s)
  2. turned on global download limits and set the limit to 100 KB/s. (result: transmission throttled itself correctly and downloaded at 100 KB/s)
  3. set the global download limit to 1 KB/s. (result: transmission throttled itself correctly and downloaded at 1 KB/s)
  4. set the global download limit to 0 KB/s. (result: transmission stopped downloading altogether, but continued uploading)
  5. turned off global download limits. (result: transmission snapped back up to 400 KB/s)
  6. turned on global download limits, which were still set to 0. (result: as with step #4, transmission stopped downloading altogether but continued uploading).

If this is not the behavior you're seeing, could you go into more details on how I can reproduce the problem?

Also, I see this is in "1.60+"... is the problem still there in the post-1.61 nightly builds?

comment:2 Changed 12 years ago by erudite

Hello charles and thanks for the reply.

Possibly I didn't make myself clear.

I am referring to Speed Limit Mode in version 1.61. Global download limits appear to work fine however when you set the speed to 0 in speed limit mode this is when I get the problem of it assuming this means infinite.

I hope you understand now.

I have not tried any of the nightly builds however I suppose I could do.

comment:3 Changed 12 years ago by charles

Yes, that makes more sense.

To test it this time, here's what I did:

  1. started downloading a torrent. no global nor per-torrent limits. speed limit mode turned off. (result: downloading the torrent at 1.7 MB/s)
  2. went to preferences, set Speed Limit Mode download cap to 20 KB/s and upload cap to 50 KB/s, and clicked the turtle to "on". (result: downloading at 20 KB/s and uploading at 50 KB/s... so the nonzero setting works)
  3. clicked the turtle back off. (result: downloading the torrent at 1.6 MB/s, uploading at about 100 KB/s)
  4. went to preferences, set the Speed Limit Mode download cap to 0, and clicked the turtle to "on". (result: no downloading at all, despite more than 10 seeds being avaialble. uploading at 50 KB/s).

Attached is a screenshot showing the 0 KB/s down, 50 KB/s up settings in the preferences dialog, and the main window statusbar showing that we actually are using 0 KB/s down and 50 KB/s up, and the inspector's peer tab showing that seeds are available to download from, so that it must be speed limit mode that's holding them back.

Changed 12 years ago by charles

comment:4 Changed 12 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

I suspect that you've got one or more torrents set to ignore the global limits.

comment:5 Changed 12 years ago by erudite

Hmmm I don't seem to be having the problem either any more. I think it was because before I rebooted. The speed shot up and then went back down again after changing the limit to zero.

Apologies and thanks.

Note: See TracTickets for help on using tickets.