Opened 12 years ago

Closed 12 years ago

#2079 closed Bug (fixed)

Transmission 1.61 crashes on Ubuntu Hardy

Reported by: stormking Owned by: charles
Priority: Normal Milestone: 1.71
Component: GTK+ Client Version: 1.61
Severity: Normal Keywords:
Cc:

Description

I installed transmission-1.61 using the .deb from http://www.getdeb.net/app/Transmission Initially, it started as expected. But as soon as I try to add a .torrent, transmission crashes, telling me:

(transmission:32119): Gtk-CRITICAL : gtk_icon_info_load_icon: assertion `icon_info != NULL' failed Segmentation fault

After this, it doesn't start, anymore, always giving me the same error message. Only deleting the added .torrent file from ~/.config/transmission/torrents/ makes it start, again. It doesn't matter if the .torrent file is added via the web interface, using the file requester or automatically.

My libgtk (since the error says Gtk-CRITICAL) is 2.12.9-3ubuntu5.

Change History (6)

comment:1 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Hi stormking,

Thanks for taking the time to fill out this bug report. However I think you'd be better off filing it through Ubuntu's bug reporting tool since it has some bells and whistles to do a postmortem on the crashed program and generate automatic reports on what it was trying to do when it crashed.

I watch Ubuntu's launchpad site for tickets too, so if you file a ticket there I'll see it.

comment:2 Changed 12 years ago by charles

  • Resolution invalid deleted
  • Status changed from closed to reopened

ticket #2166 has been marked as a duplicate of this ticket.

if someone could provide a crash report or gdb backtrace, that would help. This particular error message provided isn't much help, unfortunately.

comment:3 Changed 12 years ago by igor1st

transmission 1.70:

(gdb) bt
#0 0x0000000000429e61 in get_mime_type_icon ()
#1 0x0000000000433c47 in ?? ()
#2 0x00007f2ab19e4f55 in gtk_tree_view_column_cell_get_size () from /usr/lib/libgtk-x11-2.0.so.0
#3 0x00007f2ab19dd1ee in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#4 0x00007f2ab19deb05 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#5 0x00007f2ab19debb1 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#6 0x00007f2ab19dec49 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#7 0x00007f2ab150a82b in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#8 0x00007f2ab09dd7ab in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#9 0x00007f2ab09e0f7d in ?? () from /usr/lib/libglib-2.0.so.0
#10 0x00007f2ab09e14ad in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#11 0x00007f2ab18d8837 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x000000000042be84 in main ()

comment:4 Changed 12 years ago by charles

This appears to be triggered only on certain system configurations. In order for this to happen, gtk_icon_theme_choose_icon() and gtk_icon_theme_lookup_icon("text-x-generic") both need to fail.

I wasn't able to reproduce that system configuration issue, but by temporarily commenting out those two calls in Transmission's code, I was able to reproduce the crash.

The fix to the crash I experienced is fixed now in r8627. Could you please test a build of r8627 or higher and see if that fixes the problem for you?

If you need source code to build, you can find an automated tarball at http://build.transmissionbt.com/job/trunk-linux-inc/

comment:5 Changed 12 years ago by igor1st

Tested r8629 - it works now. Thanks.

comment:6 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.71
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.