Opened 11 years ago

Last modified 5 years ago

#2084 reopened Bug

Creation of Downloads folder even when I dont use it

Reported by: KipKurry Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.61
Severity: Minor Keywords:
Cc:

Description

By default Transmission downloads to "~/Downloads" however when you prefer and choose another folder to download, it will automatically create a new "~/Downloads" folder(eventhough it is completely useless). So every time I use Transmission I must delete that stupid "~/Downloads"-folder.

Change History (3)

comment:1 Changed 11 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

This is true and intentional in the default case, since having a default download folder that doesn't necessarily exist would cause a lot of problems and confusion.

However, I'm not able to reproduce the described behavior "when you prefer and choose another folder to download, it will automatically create a new "~/Downloads" folder".

Here's how I tested.

Session 1:

  1. delete ~/.config/transmission so that I'm starting with stock defaults
  2. start up transmission 1.61, then exit.
  3. result: ~/Downloads is created, just as you say.

Session 2:

  1. delete ~/.config/transmission so that I'm starting with stock defaults
  2. set $HOME/test as the system's default download folder. (I did this by editing ~/.config/user-dirs.dirs by hand, but different distros have GUI ways of doing this too)
  3. start up transmission 1.61, then exit.
  4. (undo the testing changes made to ~/.config/user-dirs.dirs.)
  5. result: ~/test is created. ~/Downloads is not created.

Session 3.

  1. delete ~/.config/transmission so that I'm starting with stock defaults
  2. start up transmission 1.61.
  3. go to Edit > Preferences and change the watch dir and download dir to my home directory.
  4. exit transmission.
  5. rmdir ~/Downloads, which was created on startup from the stock defaults.
  6. start up transmission 1.61, then exit.
  7. result: ~/Downloads is not created.

tl;dr: change the default paths in either Edit>Preferences, or in the desktop-wide XDG settings.

comment:2 Changed 5 years ago by fturco

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have the same problem as the person who reported this bug. Transmission keeps creating a ~/Downloads directory (please notice the letter "s" at the end) even if in ~/.config/user-dirs.dirs I have:

XDG_DOWNLOAD_DIR="$HOME/Download"

Please notice there's no "s" at the end of it. That's because in my native language we don't add an "s" at the end of plural words.

Then I noticed I had the following options in ~/.config/transmission/settings.json:

"incomplete-dir": "/home/fturco/Downloads", 
"watch-dir": "/home/fturco/Downloads",

I changed the corresponding settings in the GUI and now I hope the problem won't reappear. Anyway Transmission should have parsed my XDG_DOWNLOAD_DIR variable and not blindly assumed I like its default settings.

I'm using Transmission 2.84 GTK+ on a Parabola GNU/Linux-libre system.

comment:3 Changed 5 years ago by mike.dld

Related to #5922.

Note: See TracTickets for help on using tickets.