Opened 12 years ago

Closed 8 years ago

#2087 closed Bug (fixed)

Odd Ratio Calculation

Reported by: 103450 Owned by: charles
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.60+
Severity: Normal Keywords:
Cc: contact@…

Description

A torrent that should have a ratio of '3.3' shows up as '631'. Affects all torrents. Started with yesterday's nightly ubuntu / linux build. See screenshot. http://img199.imageshack.us/img199/6489/ratiobug.png

Change History (13)

comment:1 Changed 12 years ago by charles

At some point it forgot how much you've already downloaded for that torrent and thinks you've only downloaded 4 MB. That's why the ratio is showing up so high.

comment:2 Changed 12 years ago by 103450

You're right. I just removed and added the torrent and the ratio seems normal. There was a small 3KB file that had to be downloaded first for the seeding to begin so it was calculating the ratio based on that.

comment:3 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

A ticket with a happy ending! I should print it out and have it framed. :)

comment:4 Changed 10 years ago by charles

Ticket #3856 has been closed as a duplicate of this ticket.

comment:5 Changed 10 years ago by xCrucialDudex

I don't get it. Is it not a bug? What "I just removed and added the torrent" exactly means? I mean I can do that too but that would destroy any ratio statistic in transmission for that torrent. Which isn't that big of a deal but somehow I feel tight about losing these stats.

comment:6 Changed 10 years ago by jordan

Ticket #4544 has been closed as a duplicate of this ticket.

comment:7 Changed 10 years ago by crocket

  • Component changed from GTK+ Client to Transmission
  • Resolution invalid deleted
  • Status changed from closed to reopened

This bug ticket should be reopened.

Original seeders have downloaded size of 0byte or 2~3KiB(which is a bug, too). And seeding ratio calculation is severely wrong for original seeders or those who removed and reopened a torrent and verified the local data.

The seeding ratio must be "uploaded size/posessed size" but not "uploaded size/downloaded size" to be accurate.

comment:8 Changed 10 years ago by livings124

  • Resolution set to invalid
  • Status changed from reopened to closed

Ratio is defined as amount uploaded divided by downloaded, not possessed. The fact that there's a download size, which is a separate issue, makes this calculation correct.

comment:9 Changed 9 years ago by Malizor

  • Cc contact@… added
  • Resolution invalid deleted
  • Status changed from closed to reopened

I reported #4968 which appears to be the same issue. In my case, this behaviour leads to Transmission crashes so this has to be a valid bug.

http://malizor.org/public/images/mad-ratio.png

The file was on my system before starting the torrent, so transmission downloaded 0B. It worked fine (it probably computed the ratio as uploaded/possessed) but at some point, a few days latter, it decided to download '174 B' (according to the web interface), which caused the ratio to skyrocket (ratio is now uploaded/downloaded). And it increased at a ~5000/s rate!

It increased so quickly that about a day latter, transmission crashed (I guess it reached INT_MAX).

Removing and re-adding the torrent fix the problem for a time. Until transmission decides to download a few bytes...

This happened more than 5 times to me in the last few months, so it's not that rare.

comment:10 Changed 9 years ago by livings124

Are you modifying the file after downloading? That would explain the couple of bytes downloaded and the huge ratio.

comment:11 Changed 9 years ago by Malizor

No, I'm not modifying my files. I even excluded the folder from my backup script, so only Transmission should access them, even just for reading.

176 bytes is really small, much smaller than a part of the file (for this torrent, it's 1,336 pieces @ 512.0 KiB). AFAIK, if the file was modified, the whole relevant part would have been re-downloaded, wouldn't it?

Perhaps Transmission counts some specific dialog with the tracker or a peer as a download?

comment:12 Changed 9 years ago by Malizor

It happened again last night. Transmission downloaded 216 bytes from the "ubuntu-12.04-desktop-amd64.iso" torrent, so the ratio is now "151001951". I paused the torrent for now.

Do you know of any log that I could provide to help debugging this issue?

comment:13 Changed 8 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

No one else has reported this, and that ratio is correct for the amounts uploaded and downloaded. It is likely the file is being modified.

Note: See TracTickets for help on using tickets.