Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2111 closed Bug (fixed)

session-set causes crash on second attempt

Reported by: ajf88 Owned by: charles
Priority: Normal Milestone:
Component: Daemon Version: 1.61+
Severity: Normal Keywords:
Cc:

Description

Using r8493. Reproduce by sending two session-set requests (no changes to settings necessary). The first one works fine, but the second one causes this backtrace.

http://pastebin.ca/1432474

Change History (8)

comment:1 Changed 12 years ago by ajf88

As requested, the other useful backtrace:

http://pastebin.ca/1432463

comment:2 Changed 12 years ago by Waldorf

Asset msg + crash log:
http://transmission.pastebin.com/f127b3601

I trigger it by toggling the 'enable port forwarding' check box a few times.

comment:3 Changed 12 years ago by ajf88

Hmm. So you're saying you encounter this bug only when enabling port forwarding as opposed to making no changes?

I find this line in the backtrace interesting because it suggests (to me at least, but I'm no expert on the Transmission code/gdb or even C) that Transmission is mistakenly enabling port forwarding.

#8 0x0000000000417294 in tr_sessionSetPortForwardingEnabled (session=0x69c210, enabled=1 '\001') at session.c:1650

I think I can rule out my RPC client mistakenly enabling port forwarding because I tested enabling/disabling port forwarding with 1.61 and all is as expected.

As always, thanks for your great work.

comment:4 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.70

comment:5 Changed 12 years ago by charles

  • Owner set to charles
  • Status changed from new to assigned

possible fix in r8538

comment:6 Changed 12 years ago by ajf88

  • Resolution set to fixed
  • Status changed from assigned to closed

I can confirm this fix works. Closed.

comment:7 Changed 12 years ago by charles

  • Milestone 1.70 deleted

comment:8 Changed 12 years ago by livings124

  • Version changed from 1.61 to 1.61+
Note: See TracTickets for help on using tickets.