Opened 12 years ago

Closed 12 years ago

#2115 closed Enhancement (duplicate)

Display swarm size in main Gtk window

Reported by: jch Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.61
Severity: Normal Keywords:
Cc:

Description

The main Gtk window only displays the number of connected peers. It'd be great if it could display something like

downloading from 1 of 3 connected peers (93 peers in swarm)

where 93 is an estimate of the total number of peers in the swarm, whether obtained from the tracker, the DHT or PEX.

This would make it possible to gauge the health of a recently added torrent (before we're connected to many peers) without opening the torrent details window. (Additionally, it would stop the misunderstanding that many people have that uTorrent finds more peers than Transmission, but that's now my main point.)

I have no idea whether this applies to the other GUIs to, so not setting the component to GTK.

--Juliusz

Change History (3)

comment:1 Changed 12 years ago by livings124

I'm going to say that this is overkill. That information crowds the main window without being as useful as the other peer counts.

comment:2 Changed 12 years ago by charles

This ticket isn't exactly a duplicate of #1599, but they're very close... Juliusz, do you think that #1599 would address the concerns outlined in this ticket?

comment:3 Changed 12 years ago by jch

  • Resolution set to duplicate
  • Status changed from new to closed

Indeed, marking as duplicate of #1599. Sorry for that.

--Juliusz

Note: See TracTickets for help on using tickets.