Opened 12 years ago

Closed 12 years ago

#2124 closed Enhancement (duplicate)

Disk read performance / Read-Buffer

Reported by: sopeters Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.61
Severity: Normal Keywords:
Cc:

Description

Hi,

We run several transmission instances and each of them have multiple torrents.

Noticing the very bad read performance and constant i/o on our disks I am wondering what the read buffer is TransmissonBT is using?

I am aware requests for file-parts are random but would expect a setting in transmission to specify the read buffer. With lots of memory (RAM) these days it should be possible to buffer some MBs to avoid constant access to the disks (and very high i/o wait).

Can you tell me more about the standard buffer transmissionBT uses and how to improve the disk read performance.

Let me know if you need more information

Thanks Sven

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1521, so let's continue this thread there.

Right now the question of IO buffering is up for grabs. If you have suggestions on how to make it better, please add them to #1521. Since you're using several instances in a high-volume situation, it's probable that you have better hands-on knowledge of what the best practices are. :)

Is this something that you'd be available for testing patches, or, better yet, writing them? This is a legitimate concern that I'd like to see addressed.

Note: See TracTickets for help on using tickets.