Opened 12 years ago

Closed 12 years ago

#2125 closed Bug (fixed)

Get svn revision number with autoconf rather than make

Reported by: geirha Owned by: charles
Priority: Low Milestone: 1.70
Component: Transmission Version: 1.61+
Severity: Minor Keywords:
Cc:

Description

wereHamster on irc suggested putting the version information into a version.h.in should hopefully resolve problems with building outside the svn-tree. I've given a go at doing the change, and made a patch that seems to do the trick.

My knowledge of autotools is limited, so please review it to make sure it's done properly.

Attachments (2)

transmission_version_h_in.patch (2.6 KB) - added by geirha 12 years ago.
20090528-130038.log (126.4 KB) - added by ZogG 12 years ago.
compile log

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by geirha

comment:1 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.70
  • Owner set to charles
  • Status changed from new to assigned

Looks right to me. Let's check it in and see if anyone screams.

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 12 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

reopened by request of ZogG

Changed 12 years ago by ZogG

compile log

comment:4 Changed 12 years ago by charles

Ticket #2138 has been closed as a duplicate of this ticket.

comment:5 Changed 12 years ago by charles

I've checked in a new script, "update-version-h.sh", which is invoked by autogen.sh and which will use svnversion if available, and grep for the highest $Id$ in the source code otherwise. This should solve the problem of the revision numbers being "exported".

However before closing this ticket I'd like to get feedback from kab or ZogG to get confirmation on whether or not this is really a fix...

comment:6 Changed 12 years ago by jhujhiti

  • Resolution set to fixed
  • Status changed from reopened to closed

Looks fixed with r8587

Note: See TracTickets for help on using tickets.