Opened 12 years ago

Closed 12 years ago

#2127 closed Bug (worksforme)

Selectively downloading files in a multi-file torrent causes some selected files not to complete

Reported by: Sesquipedalian Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.61
Severity: Major Keywords: needinfo
Cc:

Description

I have recently been downloading some torrents that had multiple files in them. I didn't need the first few files in the torrent, so I deselected them in the inspector's file list. But this caused the first file that I did want to never complete its download. The file will get to over 99% complete, but never finish. I end up with a file list like this:

file 1 (0%) (deselected) file 2 (0%) (deselected) file 3 (99.4%) (selected) file 5 (100%) (selected) file 6 (100%) (selected) file 7 (100%) (selected) . . .

Transmission will continue to download indefinitely at a low rate (say, 20 KB/s), but never finish.

My guess is that one of the pieces straddles the end of the unwanted file and the beginning of the wanted one. Since Transmission keeps downloading but never finishes the file, my guess is that Transmission keeps requesting the piece because it is needed for the wanted file, but then discarding it because it is part of the unwanted file.

As a workaround, if I select the preceding file in the list (file 2 in my example above), then file 3 will eventually get its last piece.

Change History (5)

comment:1 Changed 12 years ago by charles

Could you please mail me the .torrent to charles at transmissionbt.com ?

comment:2 Changed 12 years ago by charles

  • Keywords needinfo added

Sesquipedalian: I haven't heard back from you yet. I can't reproduce this problem and need more information to go on.

comment:3 Changed 12 years ago by charles

Definitely can't reproduce this.

I've tested twice now. Here's how I did the second test, which was the simpler of the two:

  • I downloaded this public torrent from legaltorrents.com
  • Then I added some debug code to libtransmission to find two files that share a piece. Result: In the case of the above torrent, all of the files shared a piece.
  • I added the torrent to Transmission, and while adding, deselected all the files except the second one. That way the first piece in file number two straddles an unwanted file (file one) and a wanted one (file two). Result: file number two downloaded and hit 100% in about three seconds.

comment:4 Changed 12 years ago by charles

feedback from IRC user geirha, who helpfully tried downloading every other file in this torrent. He reports: "All the selected files were downloaded 100%. This is T 1.61 (8385)"

comment:5 Changed 12 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

IRC user Waldorf also reports successful 100% downloads when using file selection.

I'm closing this ticket as "worksforme" for now.

Sesquipedalian: if the problem persists for you, please do contact me so I can test out the same .torrent that you're using.

Note: See TracTickets for help on using tickets.