Opened 12 years ago

Closed 12 years ago

#2130 closed Bug (duplicate)

configure script broken when using --disable-gtk and --disable-nls

Reported by: sarav Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.61
Severity: Normal Keywords: patch-needed
Cc:

Description

This is the configure command I execute:

./configure --host=arm-marvell-linux-gnu \
                        --target=arm-marvell-linux-gnu \
                        --build=i686-pc-linux \
                        --disable-gtk --disable-nls \
                        --prefix=/usr/local \
                        CFLAGS="-I/snipped/cc/include -I/snipped/out/temproot/usr/local/include -I/snipped/out/root/usr/local/include" LDFLAGS="-L/snipped/cc/lib -L/snipped/out/temproot/usr/local/lib -L/snipped/out/root/usr/local/lib" CPPFLAGS=-DTR_EMBEDDED

And the error I get is:

checking for GTK... yes
checking host system type... (cached) arm-marvell-linux-gnu
configure: creating ./config.status
config.status: creating Makefile
config.status: creating transmission.spec
config.status: creating cli/Makefile
config.status: creating daemon/Makefile
config.status: creating doc/Makefile
config.status: creating libtransmission/Makefile
config.status: creating libtransmission/version.h
config.status: creating third-party/Makefile
config.status: creating third-party/miniupnp/Makefile
config.status: creating third-party/libnatpmp/Makefile
config.status: creating third-party/dht/Makefile
config.status: creating macosx/Makefile
config.status: creating gtk/Makefile
config.status: creating gtk/icons/Makefile
config.status: creating po/Makefile.in
config.status: executing depfiles commands
config.status: executing po/stamp-it commands
config.status: error: po/Makefile is not ready.
make: *** [out/transmission/syno.config] Error 1

Why is it creating a gtk makefile? I think the po/Makefile error is related to that (I think that's what charles told over IRC).

Setting the severity as Blocker since this issue pretty much disables transmission for all embedded systems.

Change History (2)

comment:1 Changed 12 years ago by sarav

  • Summary changed from configure script tries to configure GTK even when it's disabled with --disable-gtk to configure script broken when using --disable-gtk and --disable-nls

Btw, building this on a Fedora 9 system.

comment:2 Changed 12 years ago by charles

  • Keywords patch-needed added
  • Priority changed from High to Normal
  • Resolution set to duplicate
  • Severity changed from Blocker to Normal
  • Status changed from new to closed

This appears to be a duplicate of #1885.

Note: See TracTickets for help on using tickets.