Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2141 closed Bug (duplicate)

Speeds extremely high if system time is changed

Reported by: Adys Owned by:
Priority: Low Milestone: None Set
Component: Transmission Version: 1.51
Severity: Normal Keywords:
Cc:

Description

Easy to reproduce.

  • Fire up transmission with ongoing downloads/uploads
  • Change system time 1 day backwards

Result: The speeds go up to an extreme (I was happy showing off my 30mb/s upload though). They don't reset until time is changed back.

Change History (3)

comment:1 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1385. The conclusion drawn there still stands.

comment:2 Changed 12 years ago by Adys

Would it be as hard to reset the counter every few seconds/minutes? I didn't change my system time in the intent of making transmission go crazy, I had legitimate reasons.

I understand the conclusion if it's actually hard to implement, but I don't see the issue in a sanity reset every 5 minutes or so. I'm up to multiple GBs / sec right now, I wonder if it can end up crashing after a couple of days.

comment:3 Changed 12 years ago by livings124

Maybe #529 is a better solution (and more useful - I just don't see when this situation would really come into play).

Note: See TracTickets for help on using tickets.