Opened 13 years ago

Closed 13 years ago

#2161 closed Enhancement (duplicate)

restructure transmission-daemon config system.

Reported by: Kilominha Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.61
Severity: Normal Keywords:
Cc:

Description

Hi I'm a regular user of linux daemons, working only in bash without a regular desktop, the configuration of transmission-daemon is quite different from most other daemons in linux which make's a mess for new users not familiar with transmissions custom config.

What I would like is to have lets say a configfile in /etc/transmission/trans-daemon.conf

And in this file all options should be listed:

#Open port limit: (description) $MIN-$MAX open-file-limit": 32 #peer-limit-global: (description) $MIN-$MAX peer-limit-global": 512 #peer-limit-per-torrent: (description) $MIN-$MAX peer-limit-per-torrent": 100

Configure this file and for the new settings to take, restart the daemon: hopefully: /etc/init.d/transmission-daemon restart

also add custom log to trans-daemon.conf what is listed with the -f command (foreground) should be listed in the logfile. (trans-daemon.conf) #logging #location of logfile: /var/log/transmission.log #whats beeing logged: (info, warn, error, debug) log level: debug

this would make backtracing much easier.

Change History (2)

comment:1 Changed 13 years ago by Kilominha

Edited for wrong breakpoints.

...And in this file all options should be listed:

#Open port limit: (description) $MIN-$MAX
open-file-limit": 32
#peer-limit-global: (description) $MIN-$MAX
peer-limit-global": 512
#peer-limit-per-torrent: (description) $MIN-$MAX
peer-limit-per-torrent": 100

...(trans-daemon.conf)
#logging
#location of logfile:
/var/log/transmission.log
#whats beeing logged: (info, warn, error, debug)
log level: debug

comment:2 Changed 13 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

I'm not going to create a new config parser just for the daemon, because we already have a perfectly good, human-readable and human-editable one.

However I agree with the rest of this ticket, which is a duplicate of #2119.

Note: See TracTickets for help on using tickets.