Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2168 closed Bug (fixed)

1.70 build failure in libdht

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.71
Component: Transmission Version: 1.70
Severity: Normal Keywords:
Cc:

Description

05:32 < Humihara> I'm having trouble building transmission 1.70 on freebsd. Can someone help me?
05:32 < Humihara> dht module is not compiling: "Stop in /usr/home/edu/transmission-1.70/third-party/dht."
05:33 < Humihara> dht.h:35: warning: 'struct sockaddr_in' declared inside parameter list
05:33 < Humihara> dht.h:35: warning: its scope is only this definition or declaration, which is probably not what you want
05:33 < Humihara> dht.h:36: warning: 'struct sockaddr_in' declared inside parameter list
05:33 < Humihara> dht.h:44: warning: 'struct sockaddr_in' declared inside parameter list
05:40 < stdisease> Humihara, however try adding "#include <netinet/in.h>" to dht.c, just after sys/socket.h
05:43 < Humihara> but it looks like it works with that extra include
05:44 < charles_> Humihara: what OS are you on, again?
05:45 < Humihara> freebsd 7.2

Change History (4)

comment:1 Changed 12 years ago by charles

  • Owner set to charles
  • Status changed from new to assigned

fixed in r8626; reporting upstream

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 12 years ago by jch

Applied upstream, thanks to both of you.

--Juliusz

comment:4 Changed 12 years ago by charles

Ticket #2178 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.