Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2190 closed Bug (fixed)

removing download items makes property window useless

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.72
Component: GTK+ Client Version: 1.70
Severity: Normal Keywords:
Cc:

Description

Reported by Asif Youssuff in this downstream ticket:

removing download items makes property window useless, by removing options for the selected torrent

Steps to reproduce:

  1. Begin downloading a torrent
  2. Switch to "Downloading" section of transmission (of All, Active, Downloading... etc)
  3. Select torrent, open properties window (right click, properties)
  4. Switch to files tab
  5. Remove all files from download

What happens

The properties window seems to become detached from the torrent -- the titlebar changes, the widgets disappear, etc.

Expected behavior

User should be able to continue using the properties dialog even if they have chosen to not download everything -- they may simply want to select one item, and are attempting to unselect all the items, and then select the one item that they want.

Change History (4)

comment:1 Changed 13 years ago by charles

  • Status changed from new to assigned

comment:2 Changed 13 years ago by charles

  • Summary changed from removing download items makes property window useless [edit] to removing download items makes property window useless

comment:3 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.72
  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r8666.

Note: See TracTickets for help on using tickets.