Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2198 closed Bug (fixed)

crashed with SIGSEGV in notify.c's notifyCallback()

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.72
Component: GTK+ Client Version: 1.42
Severity: Major Keywords:
Cc:

Description

Downstream ticket reported by RuiDC

https://bugs.launchpad.net/ubuntu/+source/transmission/+bug/334104

I'm not exactly sure *how* it happened -- I think that part may be fixed in newer releases -- but looking at the stack trace, it's clearly a crash being caused by dereferencing a null pointer:

#0 notifyCallback (n=<value optimized out>, action=<value optimized out>, gdata=<value optimized out>) at notify.c:54 tor = (tr_torrent *) 0x0 info = (const tr_info *) 0x0

and, a few lines later, we have this:

char * path = g_build_filename( dir, info->files[0].name, NULL );

We can prevent the crash by adding some NULL safeguards.

Change History (3)

comment:1 Changed 13 years ago by charles

  • Status changed from new to assigned
  • Version changed from 1.71 to 1.42

fixed in r8670 for 1.72

comment:2 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 13 years ago by charles

  • Severity changed from Normal to Major
Note: See TracTickets for help on using tickets.