Opened 12 years ago

Closed 12 years ago

#2210 closed Enhancement (duplicate)

max. simultaneous torrents in transmission-daemon

Reported by: DFreeze Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.71
Severity: Normal Keywords:
Cc:

Description

I'm using a bash script on my CH3SNAS landisk to control the behaviour of Transmission, right now. The advent of 1.7x gave a watch-dir for adding new torrents, so part of my script is redundant now. There is one more thing keeping me from completely throwing the bash script overboard.

My NAS has limited resources, and my router too can’t handle too many torrents at a time. I know I can throttle the connections, but with many torrents these connections would spread thin. And this doesn’t keep the router from dying, or else I wouldn’t need the script. If one setting could be added to the daemon, I would be completely content with Transmission: setting a limit to the maximum active torrents (or if you will: a max. number of downloading and another max. number for seeding torrents). This way I can just dump torrents in the watch dir as I stumble upon them, and Transmission would gracefully handle them, e.g. three at a time.

So for example: transmission-daemon s3 (for three simultaneous torrents) or transmission-daemon d3 s5 (for 3 downloads and 5 seeds simultaneous)

Change History (1)

comment:1 Changed 12 years ago by charles

  • Milestone changed from 1.80 to None Set
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket #671

Note: See TracTickets for help on using tickets.