Opened 11 years ago

Closed 11 years ago

#2235 closed Bug (duplicate)

Regular freezes when downloading to NTFS with large files

Reported by: LB06 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.72
Severity: Major Keywords: ntfs, ntfs-3g, freeze
Cc:

Description

Currently I'm using Transmission 1.72 on my OS X 10.5.7. Since I want to share data with my Linux and Windows partition, NTFS was the only viable choice to store my bulk data.

The problem is that Transmission freezes during the entire pre-allocation process. Which means that both the front-end and the back-end are frozen completely. The rest of the system is unaffected. As soon as preallocation is done (I can check with ls -lh) Tranmission unfreezes and starts downloading. But only for a few seconds. Then it freezes again for 5 seconds, unfreezes, freezes, etc. This cycles on until the torrent has been downloaded completely.

Transmission 1.71, 1.61 and 1.34 are also affected. I believe Transmission 1.34 only freezes during pre-allocation, not while leeching. I don't know about the other versions. The GTK+ version suffers from the same bug it would seem: http://forum.transmissionbt.com/viewtopic.php?f=9&t=6620&p=38501&hilit=ntfs#p38501

I tried to circumvent this bug by using my HFS+ disk as incomplete download folder, which works until the torrent has been downloaded and Transmission starts moving data to my NTFS disk.

My data:

  • Leopard 10.5.7 all patches
  • ntfs-3g 2009.4.4 external FUSE 27
  • MacFuse? 2.0.3
  • Transmission 1.72

Should you require any other information please let me know. Thank you very much!

Change History (1)

comment:1 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket #1753

Note: See TracTickets for help on using tickets.