Opened 12 years ago

Closed 12 years ago

#2238 closed Bug (fixed)

Verify status freeze

Reported by: howl Owned by: charles
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.72
Severity: Normal Keywords:
Cc:

Description

I'm using transmission-daemon but i supose that is a web interface bug.

When adding a torrent transmission starts to verify it and the progress is shown in the interface, but, when it arrives about 400 MiB to 600 MiB the status stops refreshing. Transmission doesn't stop it continue verifiying, if you refresh the page it can be seen the actual status but it remains freeze. When the check is completed the status to Seeding is well updated and its shown in the interface.

Change History (17)

comment:1 Changed 12 years ago by cico

I can confirm that.

I've tested with several torrents, on my Synology NAS as well as on my Mac, and I found out, that the status of the torrent currently being verified is always updated exact 12 times (I start as "paused" and then verify from the contextmenu).

But it has nothing to do with the filesize, one and the same torrent "freezes" at around 800MB on the NAS, where 60-70MB per "5sec refresh cycle" are verified and at around 1.9GB on the Mac where TM verifies around 160MB/5sec (with a local copy of the data).

And when this happens, only the torrent being verified is affected, the display of all other running torrents is updated ok.

comment:2 Changed 12 years ago by cico

When setting the refresh rate from 5 to 2sec the display refreshes not only 12 but 30 times, so it seems that the display update is always stalled after 60sec of verifying.

comment:3 follow-up: Changed 12 years ago by charles

  • Milestone changed from None Set to 1.73
  • Owner changed from kjg to charles
  • Status changed from new to assigned

During the verify process, the web client was only showing how complete the torrent was, not how complete the test was. I've tweaked it to behave more like the cocoa/gtk/qt clients.

comment:4 Changed 12 years ago by charles

Fixed in trunk in r8742 for 1.73.

comment:5 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 in reply to: ↑ 3 Changed 12 years ago by cico

  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry, but I must reopen this.

I just tried the mac nightly built r8744 and the above described behaviour is still there.

Replying to charles:

During the verify process, the web client was only showing how complete the torrent was, not how complete the test was. I've tweaked it to behave more like the cocoa/gtk/qt clients.

Regardless of what the the web client was or is showing, the progress of that is still shown/updated for just 1 minute, then it "freezes" until it is done.

Take an already complete torrent that you want to seed again (of course it must be big enough so that its verification lasts more than 60 seconds, let's say a 4gig dvd). Open that torrent in the web client and the verification begins, showing the progress, refreshed every 5 sec (or whatever you've set). But then after exactly 1 minute (in my case after nearly 2GB on my iMac) the status of that one torrent isn't refreshed anymore and stays at 2gig (unless you do a manual browser refresh) for another minute until the whole 4gigs of the dvd has been verified and the status changes to "seeding"

comment:7 Changed 12 years ago by charles

It's working for me.

Could you please make a video of your mac desktop where you have both the cocoa and web clients up, and try to verify a torrent?

comment:8 Changed 12 years ago by cico

Yes, I did a 1.5MB tiny screencapture (had to search for a tool first as I hadn't installed one) which shows the verifying of a 3.5 gig dvd in the web interface along with the cocoa client with transmission r8744. At 01:09 of the video (exact 1min after starting) you see the web client refreshing for the last time until finish.

Last edited 12 years ago by cico (previous) (diff)

comment:9 Changed 12 years ago by charles

Thanks very much for the video. A picture really did help in this case.

For whatever reason, your web client is still the code from yesterday. I don't know if it's a problem with the nightly build or not, but the easiest thing to check first would be to flush your web browser's cache.

In the newer build, the web client will say (for example) "Verifying local data (50% done)" instead of just "Verifying local data"....

comment:10 Changed 12 years ago by cico

Oops, a browser "empty cache" did bring up the new "(xx% tested)" status (sorry, I should have remembered cleaning the cache before posting), but it didn't solve the actual issue as you can see here...

Last edited 12 years ago by cico (previous) (diff)

comment:11 Changed 12 years ago by charles

cico: huh, I don't know what's causing that. is it repeatable, and if so, does it happen at the same point every time?

comment:12 Changed 12 years ago by cico

Yes, it is repeatable, I've tested with several torrents, each of them several times and yes, it always happens at the same point. But NOT at the same point of the torrent but after exact 60sec of verifying! If I verify the torrent from my example on my NAS, where the speed of verifying is considerably slower then on the mac of course, the status "freezes" not at 2.7GB but at around 800MB, the amount of data my Synology can verify in 1 minute.

So regardless of torrent or device, in the webinterface the display of the status of a torrent being verified is refreshed for only 60sec from verification start, then it "freezes" until the verification is complete, then the status changes to "seeding"

I mean, it's no big thing as it's "just" a display problem, the verifying itself runs correct. But I've never seen this before 1.7 so the cause for this must have appeared lately.

comment:13 Changed 12 years ago by charles

  • Milestone changed from 1.73 to None Set

comment:14 Changed 12 years ago by charles

does this problem persist in r8779 or higher?

comment:15 Changed 12 years ago by cico

yes, it does. I've just tried r8783 and it's still the same.

comment:16 Changed 12 years ago by kjg

I think the problem may be that the torrent is verifying for so long that it is no longer considered "recent" by the daemon and the web interface is only asking for updates on recently updated torrents.

comment:17 Changed 12 years ago by cico

  • Resolution set to fixed
  • Status changed from reopened to closed

I'm not sure since what built it is fixed, but at least with the main 1.74 release the problem seems to be gone. The verification status is updated properly, no matter how long the process lasts.

So I think this ticket can be closed.

Note: See TracTickets for help on using tickets.