Opened 13 years ago

Closed 13 years ago

#2274 closed Bug (invalid)

Transmission uses wrong icon size in notification area.

Reported by: perfectska04 Owned by: charles
Priority: Low Milestone: None Set
Component: GTK+ Client Version: 1.72
Severity: Minor Keywords:
Cc:

Description

When a GTK theme specifies small icons for buttons: gtk-icon-sizes = "gtk-button=16,16"

Transmission uses the 16px icon in the notification area of GNOME-Panel instead of 22/24px sizes. Somehow, copying the transmission icons to the current icon set or anywhere outside of /usr/share/hicolor makes the 22/24px icons appear correctly, instead of the 16px icon.

This can be reproduced by using any GTK theme with that setting in Ubuntu Linux, and Transmission seems to be the only application affected in this manner. As stated above, having all the Transmission icons in the current icon set as opposed to hicolor makes the notification area icon appear correctly.

Change History (3)

comment:1 Changed 13 years ago by perfectska04

Edit: I meant /usr/share/icons/hicolor

comment:2 Changed 13 years ago by charles

Downstream ticket: https://bugs.launchpad.net/ubuntu/+source/transmission/+bug/400371

This appears to be a GTK+ or Ubuntu problem, rather than a Transmission one: https://bugs.launchpad.net/ubuntu/+source/transmission/+bug/400371/comments/6 but I'll leave this ticket open for awhile just until we hear more information.

comment:3 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Also mentioned here as fixed by the gnome-panel upgrade: http://ubuntuforums.org/showpost.php?p=7627358&postcount=83

Note: See TracTickets for help on using tickets.