Opened 12 years ago

Closed 12 years ago

#2304 closed Bug (invalid)

transmission-daemon verify returns Success on error

Reported by: dandin1 Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.72
Severity: Normal Keywords: daemon rpc permission error
Cc:

Description

I have transmission-daemon 1.72 running, and use the web UI.

I was re-seeding a torrent which I had originally deleted. I dropped the directory containing the files in my Downloads directory, added the torrent file, and then did "verify". However, the download was still at 0%. So I tried from transmission-remote, and got the response: {"arguments":{},"result":"success"} However, the download was still at 0%! So I restarted transmission-daemon in foreground mode, and this time when I ran verify it spat out an error, telling me that permission was denied on the file. Of course, I had forgotten to set them properly!

The RPC interface should return an error if there is an error verifying, not "success".

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

The RPC interface has returned a success state indicating that the torrent has sucessfully been queued for a verify. That's not the same thing as saying that the verify was successful... if we wanted to wait for *that* state, the request could be waiting a *very* long time indeed, until the verify queue was done with the torrent.

Note: See TracTickets for help on using tickets.