Opened 12 years ago

Closed 12 years ago

#2314 closed Bug (duplicate)

Assertion failed: (tr_isSession( session ))

Reported by: cbowns Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.73
Severity: Normal Keywords:
Cc: cbowns+transmission@…, cbowns

Description

Here's a crash I just hit on Transmission 1.73, running on the latest Snow Leopard build. First time I've seen it, but figured I should submit the backtrace so someone can take a look.

Steps to reproduce: (haven't tried reproducing it so far, but this is roughly what went down)

  1. Switch Network Locations
  2. Quit Transmission.
  3. While Transmission is quitting, join a wireless network (the previous network location didn't know about this Wifi network, so the join happens shortly after switch).

Expected results: Transmission doesn't crash

Actual: Crash.

Attachments (1)

cbowns-transmission crash.txt (29.8 KB) - added by cbowns 12 years ago.
Crash log

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by cbowns

Crash log

comment:1 Changed 12 years ago by cbowns

  • Cc cbowns added

comment:2 Changed 12 years ago by livings124

Can you build a debug release and post the crash from there?

comment:3 Changed 12 years ago by cbowns

Sure, I'll give it a shot. Do you all not have the dSYMs around from each build to re-symbolicate crash reports?

comment:4 Changed 12 years ago by livings124

  • Summary changed from OS X: Snow Leopard: Transmission 1.73 (8832) crash to Assertion failed: (tr_isSession( session ))

comment:5 Changed 12 years ago by charles

> Expected results: Transmission doesn't crash
>
> Actual: Crash. 

Thanks for clarifying that. ;)

comment:6 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket #1663. Thanks for the additional crash report though!

Note: See TracTickets for help on using tickets.