Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2317 closed Enhancement (fixed)

.resume file gets saved too often

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.74
Component: libtransmission Version: 1.73
Severity: Normal Keywords:
Cc:

Description

The .resume file gets saved all the time in Transmission, causing pointless IO. It's saved on startup when the torrent is added (so on startup if you've got 100 torrents, you save 100 files, even though there's no new information). It's saved when file priorities are changed. It's saved when an announce completes. On shutdown, a running torrent's .resume is actually saved *twice* -- once from necessity, and once for good measure, I guess.

This is a pretty pointless waste of time. Instead we should set a dirty flag when these various things change, and then later use that dirty flag to decide whether or not to save the .resume file.

Change History (8)

comment:1 Changed 12 years ago by charles

  • Owner set to charles
  • Status changed from new to assigned

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

implemented the proposed solution in r8878

comment:3 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.74

this will be included in 1.74 or 1.80, whichever comes first.

comment:4 Changed 12 years ago by charles

  • Summary changed from .resume file gets saved too frequently to .resume file gets saved even when nothing's changed

comment:5 Changed 12 years ago by charles

  • Summary changed from .resume file gets saved even when nothing's changed to .resume file gets saved too often

comment:6 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission

comment:7 Changed 12 years ago by charles

xref: #2162

comment:8 Changed 12 years ago by charles

A pause-on-shutdown bug caused by r8878, and reported by KyleK, was fixed in r8940.

Note: See TracTickets for help on using tickets.