Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2333 closed Defect (duplicate)

Moved files get truncated and redownloaded

Reported by: mpe Owned by:
Priority: High Milestone: None Set
Component: Transmission Version: 1.22
Severity: Critical Keywords:
Cc:

Description

Steps:

  • start downloading a torrent
  • close TM, move the file(s) and place the torrent file along side of it (moving it from ~/.config/transmission/torrent...)
  • open TM, set config/prefs to download to the new location and to detect (new?) torrent files in that location

Result: TM ignores/deletes downloaded data and starts redownloading it.

Expected: Transmission to validate the existing files and continue downloading. i.e. like rtorrent and others (and previous gnome BT clients?) Instead it threw away a weeks worth of downloading. I'm trying to stay calm (switching from ubuntu 8.04 default to gnome-btdownload), and perhaps I should spank some ubuntu package maintainer instead, and/or this has been looong since fixed (nothing appeared on the search) but this is absolutely not what i'd expect from a serious default BT client. sorry. keep up the good work.

Change History (4)

comment:1 Changed 12 years ago by livings124

Can you verify this behavior on 1.73 and/or a current developmental release?

comment:2 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a duplicate of #1765.

comment:3 Changed 12 years ago by charles

The way to move torrents by hand in 1.22 is pretty awful. You got most of the way there, but you didn't edit the .resume files that have the per-torrent download locations stored in them. That's why 1.22 couldn't find your new files.

In 1.7x there are two new options in the Torrent > Set Location feature -- you can either have Transmission move your files, or you can also use it to tell Transmission where to find the moved files.

Lastly, #1765 (whose fix will first show up in 1.74) now has Transmission realize when a torrent's local data disappears, and instead of redownloading, prompts the user to use Torrent > Set Location.

Sorry Transmission 1.22, which is now eighteen releases old, is not up to par with what you'd expect from a serious BT client.

comment:4 Changed 12 years ago by mpe

awfull way to do what? (sorry, what is this, windows? ;-) nononooo, no flamebait, you courageuously try to defend to what seem to be false charges.. i dunno, i tried to play a vid and it didn't. bars stayed empty (didn't remember which files to exclude from download ofcourse) and a missed a night of sleep. Plus, this is one of the classic GUI annoyances, very, very testy..

would be a good time to present me with the donate button by the way.. oh wait.. found it..

pardon me.

Note: See TracTickets for help on using tickets.