Opened 13 years ago

Closed 13 years ago

#2350 closed Bug (duplicate)

QT client issue on Cygwin

Reported by: nobody Owned by: charles
Priority: Low Milestone: None Set
Component: Qt Client Version: Other
Severity: Minor Keywords: cygwin
Cc:

Description

Using nightly build

GTK compiles and works perfectly (but it's ugly as hell) - QT not so much.

When running ./configure with --disable-gtk and --disable-nls it errors out with this: config.status: error: po/Makefile is not ready. Strangely, even though I specified to DISABLE gtk, it builds makefiles for it anyway. That also explains why it errors out on the po/Makefiles - they're related to NLS which is mandatory for GTK but not for QT.

I then changed --disable-nls to --enable-nls and it compiled fine (but of course not the GUI, that needs to be done manually) So I did 'cd qt' then 'qmake-qt4 qtr.pro' then 'make' and it generates a load of errors with eventually: collect2: ld returned 1 exit status

Is this a problem on my end or an issue with QTr?

I have attached (or at least I think I have) full logs from both the ./configure with --disable-nls and the failed make from qt.

Attachments (1)

errors.zip (17.2 KB) - added by nobody 13 years ago.

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by nobody

comment:1 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

This appears to be a configuration error.

Googling for "qt undefined reference to `Unwind_SjLj_Register'" indicates the problem might be either qtr or qt or its dependencies are compiled with gcc3 and the other is gcc4.

If there is something in Transmission that could be patched for this, please let me know.

comment:2 Changed 13 years ago by nobody

  • Priority changed from Normal to Low
  • Resolution invalid deleted
  • Severity changed from Major to Minor
  • Status changed from closed to reopened
  • Summary changed from QT client doesn't compile under Cygwin to QT client issue on Cygwin

Thank you, thank you, thank you. I got the QT client to compile by changing the makefile to use gcc4 by adding '-4' to 'CC=gcc' and 'CXX=g++' in the qt makefile.

There still is the issue with 'po/Makefile not ready' when using './configure --disable-gtk --disable-nls'. It is not really important, because the workaround (enabling nls) is easy, but it is still a small bug.

Also - something strange I noticed (though perhaps I should open a separate bug report for that, if it is a bug on Transmission's end at all): the QT client can't connect to the internet, so it seems. The GTK client connects to the internet instantly and starts up- and downloading straight away, the QT client just sits there showing 0 peers for all my torrents (and yes, I did add a windows firewall exception). Not sure if this is an issue on my, QT's, or QTr's end, though, and it's also not a blocker bug because the GTK frontend works just fine.

I'm reopening this for the 'error: po/Makefile not ready' - that really does seem like a bug, seeing as it is *supposed* to not be ready as I specified --disable-nls. Changing the priority and severity to something more appropriate.

All of the above was tested with the latest nightly build - 8986.

Thanks so much for your time :-)

comment:3 Changed 13 years ago by charles

  • Resolution set to duplicate
  • Status changed from reopened to closed

nobody,

It's complaining about the po files because you appear to be building the gtk client and are missing gettext and/or intltool and/or intltoolize and/or glib-gettext. If you want to build the gtk client without translations, feel free to remove those parts from configure.ac and the warnings will go away.

I'm not sure what to make of your "configure-error-with---enable-nls" file. When I try passing in those same options to the configure script, my output differs from yours in at least two ways: (1) mine says "Build GTK+ client: no"; yours says "yes" (2) the "Configuration:" message always comes at the end of the configure session, but in your log it comes at the beginning. Thirdly, is that filename a typo? In the log you're passing "--disable-nls" but the log's filename says --enable-nls. All of these factors add up to make me wonder if the attached logfile is somehow corrupted.

Anyway, the "error: po/Makefile not ready" is a duplicate of #1885, whose status is "wontfix" until a workable solution is found. iirc the core problem was that intltool is extremely difficult to make conditional in the configure script.

Note: See TracTickets for help on using tickets.