Opened 12 years ago

Closed 9 years ago

#2353 closed Enhancement (fixed)

Automatically Remove on Completion

Reported by: raz Owned by:
Priority: Normal Milestone: 2.70
Component: Mac Client Version: 1.73
Severity: Normal Keywords: patch-needed
Cc:

Description

It would be nice if transmission could perform either of the following actions upon completion of a torrent:

  • Remove .torrent file from disk
  • Remove the torrent from the GUI list

Attached is a quick mockup of what this could look like in the preferences pane.

Attachments (1)

mocktm.png (147.0 KB) - added by raz 12 years ago.
Mockup

Download all attachments as: .zip

Change History (24)

Changed 12 years ago by raz

Mockup

comment:1 Changed 11 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

I honestly don't see this happening. Transmission does not maintain a connection to the torrent file when added, so that option doesn't make sense. The other option, to remove from the list after completion, I don't see being desirable for enough users.

comment:2 Changed 11 years ago by charles

  • Resolution wontfix deleted
  • Status changed from closed to reopened

says crashlanding:

After a torrent has finished downloading and seeding, it's still in the torrent list and needs to be manually removed. I think a lot of people would like to remove it automatically, making Transmission completely autonomous and capable of functioning in the background.

The developers suggested that not a lot of people want this feature, but I disagree. Auto-add, auto-seed, and auto-complete are possible, so why not auto-delist?

comment:3 Changed 11 years ago by charles

Ticket #2499 has been closed as a duplicate of this ticket. Ticket #2469 has been closed as a duplicate of this ticket.

comment:4 Changed 11 years ago by Rolcol

I could see of a way to implement this. Add an option in the application preferences globally to remove torrents when they hit their share ratio. Then have an option in the Inspector/Properties? window under Options to remove it when sharing finishes which does not follow the global setting.

I could see myself using this but I don't consider it high priority for myself.

comment:5 Changed 11 years ago by blackjancsi

  • Component changed from Transmission to Daemon
  • Keywords Automatic Daemon Moving Completed Torrents added
  • Priority changed from Normal to Low
  • Severity changed from Normal to Minor
  • Version changed from 1.73 to 1.76

I would also vote for this - but ALSO moving the completed file(s)/folder to another folder (e.g. completed_downloads), and the torrent file to another folder (e.g. completed_torrents) as it works in Bittorrent.

comment:6 Changed 11 years ago by livings124

  • Version changed from 1.76 to 1.73

comment:7 Changed 11 years ago by livings124

  • Component changed from Daemon to Transmission

comment:8 Changed 11 years ago by datapharmer

  • Keywords seeding complete added
  • Version changed from 1.73 to 1.92

ticket #3053 closed as a duplicate of this.

I also agree that it would be nice to have this. This is especially useful for those using 3rd party extensions such as automatic. If you have torrents being added by a feed the list can be long and it would be nice to see only active torrents.

comment:9 Changed 11 years ago by livings124

  • Version changed from 1.92 to 1.73

comment:10 Changed 11 years ago by charles

  • Keywords patch-needed added; Automatic Daemon Moving Completed Torrents seeding complete removed

I'm neutral on this ticket and livings is against it.

Unless someone wants to write a patch for this, it's probably not going to be added to Transmission.

comment:11 Changed 11 years ago by livings124

#3250 is a duplicate of this.

comment:12 Changed 10 years ago by ichiban

hope this is added soon. this is very necessary for automation so once finished seeding the item can be removed from the list.

comment:13 Changed 10 years ago by livings124

#3612 covers moving the data on completion.

comment:14 Changed 10 years ago by livings124

#4020 overlaps with this

Last edited 10 years ago by livings124 (previous) (diff)

comment:15 Changed 9 years ago by akira28

My two cents: the second part of the ticket (Remove the torrent from the GUI list) discourages seeding, so I would suggest not to implement it.

comment:16 Changed 9 years ago by aonez

You can show/hide items in the list by status... So you can easily know with ones are active or done. I'll not use this feature but maybe some people will.

comment:17 Changed 9 years ago by JustMe

This feature would be a great feature. Not all people use Torrents for sharing files to people and requires seeding.

The ability to use BIT based xfers if very relative.. if you want to move or sync large files with low cost bandwidth this tool has great value.

I would much rather support an OSX application.

Thank you for consideration.

Me

comment:18 Changed 9 years ago by livings124

  • Component changed from Transmission to Mac Client
  • Milestone changed from None Set to 2.70
  • Priority changed from Low to Normal
  • Severity changed from Minor to Normal

Hijacking for the Mac client.

comment:19 Changed 9 years ago by livings124

r13377 adds this option to the inspector in the Mac client

comment:20 Changed 9 years ago by livings124

r13378 adds a default option in preferences

comment:21 Changed 9 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:22 Changed 9 years ago by livings124

  • Resolution fixed deleted
  • Status changed from closed to reopened

This was temporarily reverted for 2.61 with r13398.

comment:23 Changed 9 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

re-added in r13409

Note: See TracTickets for help on using tickets.