Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2384 closed Bug (fixed)

Crashes when some invalid torrents are added

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.75
Component: libtransmission Version: 1.74
Severity: Major Keywords:
Cc:

Description

Reported by Flemzard in irc.

The line "tor->lastPieceSize = info->totalSize % info->pieceSize" in torrentRealInit() is causing an invalid floating point exception error for torrents that don't have a proper piece size:

05:49 < Flemzard> [16:26:38.324] Invalid metadata entry "info"
05:49 < Flemzard> Floating point exception

Change History (3)

comment:1 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
  • Owner set to charles
  • Severity changed from Normal to Major
  • Status changed from new to assigned

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in trunk by r9041 for 1.75 or 1.80, whichever comes first

comment:3 Changed 12 years ago by charles

Ticket #2415 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.