Opened 12 years ago

Closed 12 years ago

#2397 closed Bug (duplicate)

torrent state not saved properly on shutdown

Reported by: reardon Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.74
Severity: Normal Keywords: torrent state; shutdown
Cc:

Description

Environment: Linux (Debian 5, Gnome)

Transmission 1.74, daemon and gtk

Load: 500+ torrents across 4 private trackers

Repro: using either GTK client or using a third-party daemon client (I use transmission-remote, the Lazarus/Pascal? client)

I paused anywhere from 5 to 150 torrents. I use either (1) start-stop-daemon at commandline, implying SIGTERM or (2) directly use SIGKILL or (3) exit manually from the GTK client.

Problem: only a portion (half or less) of the paused/stopped torrents are kept in that state on restart. The rest are treated active torrents.

This appears to be some kind of shutdown race-condition, given the variable effects. On some shutdowns, most of the paused torrents were kept paused. On others, particularly when those torrents were paused via the rpc interface into the daemon, the torrents were restarted as active on the next instantiation of transmission.

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from torrent state saved properly on shutdown to torrent state not saved properly on shutdown

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug is a duplicate of bug #2520, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide. Additionally, any further discussion regarding the bug should occur in the other report.

Note: See TracTickets for help on using tickets.