Opened 13 years ago

Closed 13 years ago

#2413 closed Bug (invalid)

Assertion failed: (ccp->sizeWhenDoneLazy <= ccp->tor->info.totalSize)

Reported by: hiro Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.74+
Severity: Normal Keywords:
Cc:

Description (last modified by charles)

Transimission Crash, just in download a files, and just one time

Process:         Transmission [218]
Path:            /Applications/Transmission.app/Contents/MacOS/Transmission
Identifier:      org.m0k.transmission
Version:         1.75 (9112)
Code Type:       X86-64 (Native)
Parent Process:  launchd [157]

Date/Time:       2009-09-15 15:57:02.309 +0200
OS Version:      Mac OS X 10.6.1 (10B504)
Report Version:  6

Interval Since Last Report:          130536 sec
Crashes Since Last Report:           5
Per-App Interval Since Last Report:  1449 sec
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      5B434509-71F5-4FE8-A4A3-6D5B716D5E83

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Crashed Thread:  2

Application Specific Information:
Assertion failed: (ccp->sizeWhenDoneLazy <= ccp->tor->info.totalSize), function tr_cpSizeWhenDone, file /Users/mitchell/Desktop/Transmission_1.7x/libtransmission/completion.c, line 97.


Thread 0:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib             	0x00007fff87ab3d7a mach_msg_trap + 10
1   libSystem.B.dylib             	0x00007fff87ab43ed mach_msg + 59
2   com.apple.CoreFoundation      	0x00007fff86151ce2 __CFRunLoopRun + 2002
3   com.apple.CoreFoundation      	0x00007fff8615103f CFRunLoopRunSpecific + 575
4   com.apple.HIToolbox           	0x00007fff86850c4e RunCurrentEventLoopInMode + 333
5   com.apple.HIToolbox           	0x00007fff86850a53 ReceiveNextEventCommon + 310
6   com.apple.HIToolbox           	0x00007fff8685090c BlockUntilNextEventMatchingListInMode + 59
7   com.apple.AppKit              	0x00007fff82abc520 _DPSNextEvent + 718
8   com.apple.AppKit              	0x00007fff82abbe89 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 155
9   com.apple.AppKit              	0x00007fff82a81a7d -[NSApplication run] + 395
10  com.apple.AppKit              	0x00007fff82a7a798 NSApplicationMain + 364
11  org.m0k.transmission          	0x00000001000015a1 0x100000000 + 5537
12  org.m0k.transmission          	0x0000000100001510 0x100000000 + 5392

Thread 1:  Dispatch queue: com.apple.libdispatch-manager
0   libSystem.B.dylib             	0x00007fff87accb16 kevent + 10
1   libSystem.B.dylib             	0x00007fff87acea19 _dispatch_mgr_invoke + 154
2   libSystem.B.dylib             	0x00007fff87ace6d6 _dispatch_queue_invoke + 195
3   libSystem.B.dylib             	0x00007fff87ace1f6 _dispatch_worker_thread2 + 244
4   libSystem.B.dylib             	0x00007fff87acdb28 _pthread_wqthread + 353
5   libSystem.B.dylib             	0x00007fff87acd9c5 start_wqthread + 13

Thread 2 Crashed:
0   libSystem.B.dylib             	0x00007fff87b83a8d usleep$NOCANCEL + 0
1   libSystem.B.dylib             	0x00007fff87ba307c abort + 93
2   libSystem.B.dylib             	0x00007fff87b900b4 __pthread_markcancel + 0
3   org.m0k.transmission          	0x000000010006cc52 0x100000000 + 445522
4   org.m0k.transmission          	0x000000010006ce55 0x100000000 + 446037
5   org.m0k.transmission          	0x0000000100065bf7 0x100000000 + 416759
6   org.m0k.transmission          	0x00000001000759d4 0x100000000 + 481748
7   org.m0k.transmission          	0x000000010009bd2c 0x100000000 + 638252
8   org.m0k.transmission          	0x0000000100075852 0x100000000 + 481362
9   libSystem.B.dylib             	0x00007fff87aecf66 _pthread_start + 331
10  libSystem.B.dylib             	0x00007fff87aece19 thread_start + 13

Change History (5)

comment:1 Changed 13 years ago by charles

Thank you for taking the time to report this bug and helping to make Transmission better. Please answer these questions:

  • Is this reproducible?
  • If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

comment:2 Changed 13 years ago by charles

  • Description modified (diff)

comment:3 Changed 13 years ago by charles

  • Description modified (diff)

comment:4 Changed 13 years ago by livings124

hiro: ping

comment:5 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. Thanks again!

Note: See TracTickets for help on using tickets.