Opened 12 years ago

Closed 12 years ago

#2415 closed Bug (duplicate)

No announce entry torrent will always crash the daemon 1.74 (8994)

Reported by: skygunner Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.74+
Severity: Critical Keywords: announce invalid metadata
Cc: jch@…

Description

Some torrents doesn't have any announce entry in the torrent file, only rely on DHT and peer exchange.These kind of torrent file will crash always crash the daemon.

Running transmission-daemon 1.74 (8994) on FreeNAS 0.7 RC1 4735 i386 (FreeBSD 7.2) I remember if a torrent file is invalid to transmission, it will report as "xxxxx.torrent is not a valid torrent file. The torrent file cannot be opened because it contains invalid data." or similar.

But with this case I tried, invalid torrents files always crashes the daemon immediately after I tried to add it. If I run it fore ground, message is [code] [23:41:58.457] 777: Invalid metadata entry "announce" Floating point exception code

These torrent files doesn't have a malformed tracker address, they don't have any tracker info/announce entry at all! Only rely on DHT and peer exchange. I think that's why they crashes the daemon. After adding an announce entry to the torrent file (using BitComet? and save as), it can be added to transmission-daemon without problem.

The torrent file can be found here http://dl.getdropbox.com/u/231367/invalidMetaEntryAnnounce1.torrent another one http://dl.getdropbox.com/u/231367/invalidMetaEntryAnnounce2.torrent

See ticket 2384(fixed) Crashes when some invalid torrents are added http://trac.transmissionbt.com/ticket/2384 One thread talk about invalid metadata entry "announce" http://forum.transmissionbt.com/viewtopic.php?f=5&t=5788&start=0&hilit=Invalid+metadata+entry+announce Another one http://forum.transmissionbt.com/viewtopic.php?f=5&t=5788&start=0&hilit=Invalid+metadata+entry+announce

I can't build the tar ball for 1.75 at this moment, so don't know if 1.75 has fixed this? If not, can we make transmission-daemon to skip the step trying to check/connect to the tracker? Maybe give a warning no tracker found and DHT needs to be enabled to be able to download it? Or even add a default tracker server?

Attachments (2)

invalidMetaEntryAnnounce1.torrent (158.1 KB) - added by skygunner 12 years ago.
invalid entry announce
777.torrent (158.2 KB) - added by skygunner 12 years ago.
after adding tracker using BitComet? (may cleaned out some crab files)

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by skygunner

invalid entry announce

Changed 12 years ago by skygunner

after adding tracker using BitComet? (may cleaned out some crab files)

comment:2 Changed 12 years ago by jch

  • Cc jch@… added

comment:3 Changed 12 years ago by charles

Is this still the case in 1.75?

comment:4 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket #2384

Note: See TracTickets for help on using tickets.