Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2419 closed Enhancement (invalid)

Add support for keybind ctrl-w to close windows for gtk client.

Reported by: han Owned by: charles
Priority: Low Milestone: None Set
Component: GTK+ Client Version: 1.75
Severity: Trivial Keywords: keyboard shortcuts
Cc:

Description

Since I the keyboard a lot to navigate around and interact with windows I miss ctrl-w a lot. Yes you can use alt-f4, but ctrl-w is more subtile and easier to reach without lifting my hands.

I do use 'minimise to the tray'.

Change History (4)

comment:1 Changed 13 years ago by han

charles| Han: and what do we do if the tray icon is turned off
    Han| Just like other gtk-applications, like firefox. Close the window. This is also practical if you open prefs, stats or props.

comment:2 Changed 13 years ago by charles

11:59 <@charles> Han: it seems really strange to me to have "close window" in a monowindow, tabless app
12:00 < Han> It's not a mono window application, and if you do use the tray it's very practical.
12:00 <@charles> and the tray icon is turned off by default, so most users will have no clue what the "close" menu does differently from "exit"
12:01 < Han> Really? It's a standard keybind in both windows and gtk
12:01 < KyleK_> Han: I must disagree: Ctrl-W is not standard at all in windows
12:02 <@charles> Han: I'm trying out various dialogs at random in gnome apps and coming up short
12:02 < Han> :-$ looks it up.
12:02 < KyleK_> and you'll only find it MDI applications
12:02 <@charles> gnome-terminal > edit > profiles, ctrl-w does nothing
12:02 <@charles> pidgin > accounts > manage accounts, ctrl-w does nothing
12:03 < KyleK_> by default, in MDI apps closing a window is (by default) done via Ctrl-F4
12:03 < KyleK_> Ctrl-W came with Firefox, I believe
12:03 < KyleK_> (and I got addicted to it in no time :p)
12:03 <@charles> calculator > help > about, ctrl-w does nothing
12:04 <@charles> this is only for multi-document accounts.  the gnome hig says ctrl-w should be used to "close the current document"
12:05 < Han> ctrl-w closes an internet explorer window here.
12:06 < Han> Even without confirmation. :-D
12:07 <@charles> who cares about internet explorer.... :)
12:08 < Han> Sigh, it's the standard application for windows.
12:08 < KyleK_> IE copied it from Mozilla
12:09 <@charles> they're both multidocument apps
12:09 <@charles> how does any of this apply to Transmission
12:09 < KyleK_> well, IE wasn't until IE8
12:10 < Han> I'm not going to repeat my arguments.
12:10 <@charles> KyleK_: yes it was; there were separate windows
12:10 <@charles> KyleK_: yes it was; there were separate windows
12:10 <@charles> Han: ?
12:10 <@charles> Han: where did you explain how a multidocument metaphor applies to Transmission?
12:11 < KyleK_> hm, true
12:11 < KyleK_> anyway
12:11 < Han> "This is also practical if you open prefs, stats or props."
12:11 <@charles> wtf?
12:12 <@charles> Han: find me a gtk app that uses ctrl-w to close the prefs dialog
12:12 < KyleK_> do you still think the first issue I brought up (the proper ID for identifying PEX messages) is not a bug?
12:12 < Han> charles, firefox
12:12 <@charles> KyleK_: I'm sorry, I got distracted by this other discussion
12:12 <@charles> Han: I said gtk app
12:13  * kjg likes using command-w and NOT having ok buttons in preferences in mac apps
12:14  * lenk likes the good old 'escape' for 'cancel'
12:14 <@kjg> but obviously the gtk HIG should be followed for gtk apps
12:14  * livings likes to follow the HIG
12:15  * KyleK_ likes beer
12:15 <@charles> I've tried a handful of gnome apps and none of them follow this idiom
12:15 < lenk> Hm, we should all fork our own version of transmission. Except that I don't - it seems T already does the escape thing ;).
12:16 < Han> :-)
12:16 < Han> hmmm indeed, they don't
12:16 < Han> weird

comment:3 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

comment:4 Changed 13 years ago by livings124

  • Milestone changed from 1.80 to None Set
Note: See TracTickets for help on using tickets.