Opened 12 years ago

Closed 12 years ago

#2429 closed Bug (worksforme)

crash in tr_torrentGetMTimes()

Reported by: charles Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.75
Severity: Normal Keywords:
Cc:

Description


Process: Transmission [17362]
Path: /Applications/Transmission.app/Contents/MacOS/Transmission
Identifier: org.m0k.transmission
Version: 1.75+ (9121)
Code Type: X86-64 (Native)
Parent Process: launchd [116]

Date/Time: 2009-09-15 23:57:33.629 +0800
OS Version: Mac OS X 10.6.1 (10B504)
Report Version: 6

Interval Since Last Report: 14221 sec
Crashes Since Last Report: 1
Per-App Interval Since Last Report: 7 sec
Per-App Crashes Since Last Report: 1
Anonymous UUID: E32511A0-214E-485E-99B3-2F12E714096B

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Application Specific Information:
Assertion failed: (tr_isTorrent( tor )), function tr_torrentGetMTimes, file /Users/sheila/transmission/trunk/libtransmission/torrent.c, line 1978.


Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 libSystem.B.dylib 0x00007fff83152ff6 __kill + 10
1 libSystem.B.dylib 0x00007fff831f4072 abort + 83
2 libSystem.B.dylib 0x00007fff831e10b4 __pthread_markcancel + 0
3 org.m0k.transmission 0x0000000100064b92 tr_torrentGetMTimes + 274
4 org.m0k.transmission 0x0000000100084320 tr_torrentLoadResume + 1680
5 org.m0k.transmission 0x0000000100061df2 tr_torrentNew + 1522
6 org.m0k.transmission 0x0000000100027ac0 -[Torrent(Private) initWithPath:hash:torrentStruct:lib:downloadFolder:useIncompleteFolder:incompleteFolder:waitToStart:groupValue:addedTrackers:] + 768
7 org.m0k.transmission 0x0000000100021e1f -[Torrent initWithHistory:lib:forcePause:] + 303
8 org.m0k.transmission 0x0000000100003aae -[Controller awakeFromNib] + 2542
9 com.apple.CoreFoundation 0x00007fff84bac83d -[NSSet makeObjectsPerformSelector:] + 205
10 com.apple.AppKit 0x00007fff81abec47 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1445
11 com.apple.AppKit 0x00007fff81abce7d loadNib + 226
12 com.apple.AppKit 0x00007fff81abc38a +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 248
13 com.apple.AppKit 0x00007fff81abc1c2 +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 326
14 com.apple.AppKit 0x00007fff81ab9743 NSApplicationMain + 279
15 org.m0k.transmission 0x0000000100001f61 main + 113
16 org.m0k.transmission 0x0000000100001ec4 start + 52

From: http://forum.transmissionbt.com/viewtopic.php?p=40677#p40677

Change History (2)

comment:1 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
  • Owner set to charles

comment:2 Changed 12 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

I'm not able to reproduce this bug, either from running Transmission or from inspecting the code, and it has only been reported once. I've added some more assertions into trunk in r9218 to help smoke out any possible problems, but until there's more information I'm going to mark this one up to weather balloons and swamp gas.

Note: See TracTickets for help on using tickets.