Opened 12 years ago

Closed 12 years ago

#2443 closed Bug (duplicate)

Transmission Crashes OS X

Reported by: odon Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.75
Severity: Critical Keywords:
Cc: jch@…

Description

Transmission 1.75 is crashing my copy of OS X 10.5.8. When I first start Transmission everything seems to work fine, however, after a while, I can no longer open new applications, OS X reports "application not responding" when I try to use the context menu from Dock with Transmission. Force quitting Transmission does nothing (it remains open), as does Kill. The my machine refuses to restart or shutdown, forcing me to kill the computer's power.

I first encountered this issue several months ago, after the OS X update from 10.5.7 to 10.5.8 and decided to temporarily use a different BT client. I've checked Console but found nothing recent (the last Transmission entry in CrashReporter? was from April).

I've encountered the problem with both over 100 torrents open or just one torrent open, and at a variety of different permitted speeds (from 1024kb/s to 1kb/s). I haven't had any similar issues with any other software.

Change History (5)

comment:1 follow-up: Changed 12 years ago by jch

Does disabling the DHT fix the issue?

comment:2 in reply to: ↑ 1 Changed 12 years ago by jch

Replying to jch:

Does disabling the DHT fix the issue?

I mean, does it work around the issue. This is obviously a kernel bug -- under no circumstances should an unpriviledged user-space process be able to kill the system.

comment:3 Changed 12 years ago by jch

  • Cc jch@… added

comment:4 Changed 12 years ago by just some guy

You're certainly correct, but in the same vein user-space processes should avoid tickling known kernel bugs, and since Apple has shown no particular inclination to fix this... :(

For what it's worth I'm having a similar problem on 10.6.1 with 1.75 with default settings. DHT is disabled (well, it's enabled in preferences but they're private torrents.) There are no bandwidth limits in effect. I've been affected by this since... I remember it being present on 1.42 on 10.5.6 or so, but it was probably present before that.

Unfortunately there's nothing useful in my logs either. Before I was seeing warnings about running out of mbufs, nothing now though.

I hope that's of ... some use.

comment:5 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a duplicate of ticket #1201.

Please see http://forum.transmissionbt.com/viewtopic.php?f=4&t=4564&start=465 for more information.

Note: See TracTickets for help on using tickets.