Opened 12 years ago

Closed 12 years ago

#2449 closed Enhancement (duplicate)

Transactional writing to torrent, . resume and .json file

Reported by: krx Owned by:
Priority: Low Milestone: None Set
Component: Transmission Version: 1.75
Severity: Minor Keywords:
Cc:

Description

I do not know, if transmission has any transactional writing to torrent (or .resume?) files, including .json files. But if transmission daemon crashes, and it happens to crash a lot for me, I am left sometimes with incorrect entries in .json files, and all torrents open for download-writing starts to Verify, thus killing router CPU.

I do not have idea, if file system (ext3 on router in myc case) should be responsible for gracefull transactional handling of data (it is enabled in my case for both the metadata [journal] and the file data as well).

Therefore, if there any workaround with transactional writing, to escape situation with mangled .json files and the currupted torrents/.resumes, that would be appreciated.

Sorry, if this topic is blunt due to my incompetence on the topic...

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #2162.

If the daemon is crashing, please report the details on that crash separately.

Note: See TracTickets for help on using tickets.