Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2450 closed Bug (fixed)

--find should not delete original

Reported by: fschulze Owned by: charles
Priority: Normal Milestone: 1.76
Component: Daemon Version: 1.75
Severity: Normal Keywords:
Cc:

Description

The --find option should *never* delete data, it's totally unexpected and I lost data because of it.

Change History (6)

comment:1 Changed 13 years ago by charles

Thank you for taking the time to report this bug and helping to make Transmission better. Please answer these questions:

  • Is this reproducible?
  • If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

comment:2 Changed 13 years ago by fschulze

I'm running transmission-daemon and use transmission-remote to manage it. When I copy the data for a torrent to another location (regardless of whether it's on the same filesystem or another) and then use --find to update the location of the torrent data to the new location, then the old copy is removed. This is totally unexpected for a command with the name --find. I'm not sure what happened so that I lost the data (probably some issue with a remote filesystem), but that's not the point of this ticket.

comment:3 Changed 13 years ago by charles

  • Keywords backport added
  • Milestone changed from None Set to 1.80
  • Owner set to charles
  • Status changed from new to assigned

fixed in trunk by r9195 for 1.80.

comment:4 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:5 Changed 13 years ago by charles

  • Milestone changed from 1.80 to 1.76

backported to 1.7x branch for 1.76 in r9361

comment:6 Changed 13 years ago by charles

  • Keywords backport removed
Note: See TracTickets for help on using tickets.