Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2451 closed Bug (invalid)

Resume All After Seeding Completes Resumes Seeding

Reported by: TheDov Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.75
Severity: Normal Keywords:
Cc:

Description

If a torrent has completed seeding (by reaching the designated ratio), and you then perform a "Pause All" and "Resume All", the completed seeds resume as well, which I don't believe is the correct behavior. They should need to be explicitly restarted first.

Change History (3)

comment:1 follow-up: Changed 12 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

It you hit "resume all" I would expect all to resume. This could be argued either way, but I'm going to put my foot down on this one.

comment:2 in reply to: ↑ 1 Changed 12 years ago by TheDov

Replying to livings124:

It you hit "resume all" I would expect all to resume. This could be argued either way, but I'm going to put my foot down on this one.

The reason this is unexpected behavior for me, is because I never explicitly paused a torrent that finished seeding, so it wouldn't make sense for an explicit action to resume it.

comment:3 Changed 12 years ago by livings124

I definitely see your argument, but there is no "right" answer, so keeping it consistent with previous answers is probably best.

Note: See TracTickets for help on using tickets.