Opened 14 years ago

Closed 14 years ago

#246 closed Bug (invalid)

Piece ???? hash FAILED

Reported by: oleo Owned by: charles
Priority: Normal Milestone: Sometime
Component: libtransmission Version: 0.80
Severity: Normal Keywords: hash
Cc: joshe

Description

When upgrading from r1874 to 2199 I've noticed that some torrents report

Piece 1035 hash FAILED
Piece 1031 hash FAILED
Piece 1034 hash FAILED
Piece 1024 hash FAILED

First I've tried with deleting torrent cache file and rechecked without success. I've also tried to use builtin SHA1 routine.

Downgrading to r1874 helped to finish torrents that previously stopped at 80%-99% and refused to continue (nn peers, dl from 0). Checking torrent consistency with libbt utility, when finished, showed 100% good torrent.

I have also tried latest r2278 without with the same problem as r2199.

It looks like problem in inout.c piece checking, but changes with new serialized checking are so big that I cannot point exactly problematic routine.

Change History (3)

comment:1 Changed 14 years ago by charles

These were incomplete torrents that gave the failed hash when you upgraded from r1874 to r2199, correct?

comment:2 Changed 14 years ago by oleo

Good point. Not shure. Will give another shot to r2278 with fresh startup and report.

comment:3 Changed 14 years ago by oleo

  • Resolution set to invalid
  • Status changed from new to closed

It turned out that this was a problem when upgrading with uncomplete torrents.

Note: See TracTickets for help on using tickets.