Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2495 closed Bug (wontfix)

Duplicate trackers are allowed to be added.

Reported by: Rolcol Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.75+
Severity: Normal Keywords:
Cc:

Description

Tested as of r9302:

Transmission does not know the difference between

http://tracker.openbittorrent.com:80/announce and
http://tracker.openbittorrent.com/announce

This allows duplicate trackers to be added.

Change History (2)

comment:1 Changed 13 years ago by charles

  • Resolution set to wontfix
  • Status changed from new to closed

The goal here is to prevent accidental duplication from human error, rather than an exhaustive test... the latter has diminishing returns IMO.

There are lots of cases that we don't test for... we don't look for ".." in the directories, or rfc2396 escaped characters. Searching for every little thing is expensive and IMO not worth the effort.

comment:2 Changed 12 years ago by charles

Ticket #3359 has been closed as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.