Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2515 closed Enhancement (invalid)

Torrent data does not move when grouped after adding

Reported by: dak180 Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.76
Severity: Normal Keywords: group
Cc:

Description

When a torrent has already been added and the group is changed (from 'no group' or any other) and the new group has a default download location different from the data's current location, it does not move to the new location.

Build: 9322

Change History (5)

comment:1 Changed 12 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 1.75+ to 1.75

This is intentional. Moving is slow and not something you would want to do by accident. Also, this would be confusing if the user already specified a custom location.

comment:2 Changed 12 years ago by Mark

  • Type changed from Bug to Enhancement
  • Version changed from 1.75 to 1.76

I agree that moving the file might be confusing if the user has already designated a specific location. But in cases where no location or group has been chosen, wether by user or automatically based on criteria, would it not make sense that changing the group of a file from "no group" to a group with a custom location would also be intended for the file to change location? I can't speak for anyone else of course, but in my case, this has been what I've wanted 100% of the time so far.

comment:3 Changed 12 years ago by livings124

There are a lot of edge cases for either case that make this a bad idea, plus the huge cost/slow-down caused by moving data.

comment:4 Changed 12 years ago by Mark

Fair enough. I can see how it might backfire. Might I suggest that instead, it might be a good idea to enable moving multiple files at once to a new folder? I get a sense that you're not big fans of moving the data :) but often I'll have 5-10 files that should've been in a different folder. Currently, I'm moving them one file at a time, but it would be nice to be able to move them all together if they have to go to the same location anyways. If not by changing the group, then at least by being able to change the location of more than one file at a time.

comment:5 Changed 12 years ago by livings124

This can already be done. Select the files, and choose the move data menu option.

Note: See TracTickets for help on using tickets.