Opened 12 years ago

Closed 12 years ago

#2518 closed Bug (fixed)

r9334 overzealously alarmist re unresponsive trackers

Reported by: m1b Owned by: charles
Priority: Normal Milestone:
Component: libtransmission Version: 1.75+
Severity: Normal Keywords:
Cc:

Description

Given a torrent with Tier 1-5 trackers. Tiers 1-3 respond and all is well. Tier 4 does not respond, and Tier 5 alternates between 403 and not responding.

1.75 works without complaint, whereas r9334 overlays the warning triangle over the torrent in the main window. This seems unnecessary given that three out of the five trackers are responding well and the torrent is entirely functional.

Change History (8)

comment:1 Changed 12 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

comment:2 Changed 12 years ago by charles

  • Component changed from libtransmission to Mac Client
  • Owner changed from charles to livings124

livings: stop moving tickets to libtransmission without giving some context of what you find the problem to be. You did this with #2504 too, only to wind up making the changes in the mac client.

This may well be a libtransmission problem, or not, but without more context I have no idea what you're expecting here.

comment:3 Changed 12 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

libtransmission is marking the torrent as an error - the Mac client simply displays that. That's all there is to this ticket.

#2504 was different - as I stated, this is the Mac client working around libtransmission's undesirable behavior (which this ticket is about).

comment:4 Changed 12 years ago by charles

  • Milestone None Set deleted
  • Status changed from new to assigned

comment:5 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk by r9354 for 1.80. Thanks for the bug report and the clear summary...

This change should prevent the alarm from sounding unless the torrent in question only has one tracker or if the torrent is from a private tracker.

comment:6 Changed 12 years ago by m1b

  • Resolution fixed deleted
  • Status changed from closed to reopened

Behavior is back in r9412 in a scenario identical to the original report.

comment:7 Changed 12 years ago by charles

m1b: I'm not able to reproduce this now. Could you give more information please? If possible could you take a screenshot of the error message, and the tracker tab in the inspector dialog?

comment:8 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

ah, it's a two-parter. There was a second place the error message could get through.

Fixed in trunk for 1.80 by r9419.

Note: See TracTickets for help on using tickets.