Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2523 closed Enhancement (wontfix)

Per torrent bandwidth allocation

Reported by: ppson Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.75
Severity: Normal Keywords: bandwidth peer torrent
Cc:

Description

I would like an option to allocate the available bandwidth on a per torrent basis. Right now Transmission seem to allocate the bandwidth based on number of peers.

The problem is that I use torrents both for public trackers and a personal private tracker. The torrents from the public trackers usually have a large number of peers while the ones on my private tracker (used to share files with friends) usually only have 1-2 peers at any given moment. This for me results in very slow transfers on the private tracker when torrents from public trackers are active. Example: Torrent #1is a public torrent with 10 peers and torrent #2 is a private torrent with 1 peer. My upload bandwidth limit is 110 KB/sec. Result: torrent #1 gets 100 KB/sec and torrent #2 gets 10 KB/sec.

I would like the example scenario to give 50% bandwidth to both torrent #1 and #2.

Change History (7)

comment:1 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

#2175 covers groups in general.

comment:2 Changed 12 years ago by livings124

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Whoops, that was for a different ticket.

comment:3 Changed 12 years ago by ppson

I didn't know that putting # followed by a number automatically generated a link to the corresponding ticket. This was not my intent, sorry.

comment:4 Changed 12 years ago by livings124

Have you tried setting the torrent's priority?

comment:5 Changed 12 years ago by ppson

Yes, and oddly setting the prority to high on the 1 peer torrent makes it halt (speed 0 KB/sec). Also since I add torrents remotely to a server running transmission using a watch folder that would not be very convenient to have to set priority to every torrent manually.

comment:6 Changed 12 years ago by charles

  • Resolution set to wontfix
  • Status changed from reopened to closed

Unless this feature is requested by more people, it's probably not going to get implemented. libtransmission's bandwidth code is very peer-oriented, and reworking it along the lines described in this ticket is not going to be trivial.

comment:7 Changed 12 years ago by ppson

OK. If the individual group bandwidth settings are implemented this will not be as much of a problem anymore, also setting priorities to groups would be a big help.

Note: See TracTickets for help on using tickets.