Opened 12 years ago

Closed 12 years ago

#2533 closed Bug (fixed)

Main window popup causes hang

Reported by: m1b Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.76+
Severity: Normal Keywords:
Cc: m1b

Description

If I click on a torrent's icon in the main window in an attempt to bring up the popup, r9413 consistently hangs while pegging the CPU. 100% reproducible, 10.5.8 ppc. Sample enclosed.

Attachments (3)

9413_popup_hang.txt (3.8 KB) - added by m1b 12 years ago.
2533_sample_2.txt (10.6 KB) - added by m1b 12 years ago.
2533_sample_3.txt (9.5 KB) - added by m1b 12 years ago.

Download all attachments as: .zip

Change History (14)

Changed 12 years ago by m1b

comment:1 Changed 12 years ago by m1b

  • Version changed from 1.76 to 1.76+

comment:2 Changed 12 years ago by m1b

  • Cc m1b added

comment:3 Changed 12 years ago by livings124

This doesn't happen for me, and the trace isn't all too helpful. Could you track down which revision this started occurring?

comment:4 Changed 12 years ago by m1b

Looks like it's necessary for the torrent in question to be a folder rather than a single file. My repro case is:
http://mirror.centos.org/centos/5.4/isos/x86_64/CentOS-5.4-x86_64-bin-DVD.torrent

comment:5 Changed 12 years ago by m1b

Adding two more samples; sample_2 was created as quickly as possible after clicking on the mouseover gear to trigger the hang, sample_3 after the cpu had been pegged for a while.

Changed 12 years ago by m1b

Changed 12 years ago by m1b

comment:6 Changed 12 years ago by livings124

  • Component changed from Mac Client to Transmission

This might be pointing at tr_torrentFiles().

comment:7 Changed 12 years ago by charles

I'm not saying it isn't tr_torrentFiles(), but FWIW I can't reproduce this with the GTK+ client.

livings124: do you see the same problem when you run the CentOS torrent in the Mac client and popping up the properties dialog?

comment:8 Changed 12 years ago by livings124

No, I can't replicate this either, but I'm on 10.6 Intel.

comment:9 Changed 12 years ago by charles

  • Component changed from Transmission to Mac Client

I put a timer on tr_torrentFiles() in libtransmission to see how long it took to call, while downloading the CentOS torrent.

** Message: calling tr_torrentFiles took 0.000231 seconds
** Message: calling tr_torrentFiles took 0.000724 seconds
** Message: calling tr_torrentFiles took 0.000754 seconds
** Message: calling tr_torrentFiles took 0.000227 seconds

** Message: calling tr_torrentFiles took 0.000207 seconds

** Message: calling tr_torrentFiles took 0.000206 seconds
** Message: calling tr_torrentFiles took 0.000223 seconds
** Message: calling tr_torrentFiles took 0.000206 seconds
** Message: calling tr_torrentFiles took 0.000206 seconds
** Message: calling tr_torrentFiles took 0.000290 seconds
** Message: calling tr_torrentFiles took 0.000219 seconds
** Message: calling tr_torrentFiles took 0.000226 seconds
** Message: calling tr_torrentFiles took 0.000206 seconds
** Message: calling tr_torrentFiles took 0.000211 seconds
^ when torrent was 0.22% complete
** Message: calling tr_torrentFiles took 0.000221 seconds
** Message: calling tr_torrentFiles took 0.000714 seconds
** Message: calling tr_torrentFiles took 0.000684 seconds
** Message: calling tr_torrentFiles took 0.000690 seconds
** Message: calling tr_torrentFiles took 0.000683 seconds
** Message: calling tr_torrentFiles took 0.000722 seconds
^ when torrent was 13% complete
** Message: calling tr_torrentFiles took 0.000220 seconds
** Message: calling tr_torrentFiles took 0.000684 seconds
** Message: calling tr_torrentFiles took 0.000727 seconds
** Message: calling tr_torrentFiles took 0.000716 seconds
** Message: calling tr_torrentFiles took 0.000713 seconds
^ when torrent was 26% complete
** Message: calling tr_torrentFiles took 0.000208 seconds
** Message: calling tr_torrentFiles took 0.000720 seconds
** Message: calling tr_torrentFiles took 0.000708 seconds
** Message: calling tr_torrentFiles took 0.000206 seconds
^ when torrent was 54% complete
** Message: calling tr_torrentFiles took 0.000237 seconds
** Message: calling tr_torrentFiles took 0.000771 seconds
** Message: calling tr_torrentFiles took 0.000206 seconds
** Message: calling tr_torrentFiles took 0.000718 seconds
** Message: calling tr_torrentFiles took 0.000714 seconds
^ when torrent was 68% complete

I don't think the problem is tr_torrentFiles().

comment:10 Changed 12 years ago by livings124

r9452 might take care of this - looks to have been a compiler bug.

comment:11 Changed 12 years ago by m1b

  • Resolution set to fixed
  • Status changed from new to closed

Verified fixed with both test case torrents using r9455

Note: See TracTickets for help on using tickets.