Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#2542 closed Bug (fixed)

Transmission freezes when using 'Move data file to...'

Reported by: Tantali Owned by: livings124
Priority: High Milestone:
Component: Transmission Version: 1.76+
Severity: Major Keywords:
Cc:

Description

Moving any data file using the 'Move data file to...' results in a freeze. Whether you move to a different drive, on the same drive, whether it's a large file or a small one or even when it's none.

If you wait a few minutes, force quit Transmission and then restart it, only one torrent's data file will be moved. (of the one or more selected torrents) In older nightlies, the only moved torrent did know where it was moved to. In newer nightlies, the torrent doesn't even know where it's data file has gone (N/A).

This started a few nightlies before 1.76 and is still present in the r9433.

Change History (14)

comment:1 Changed 10 years ago by Tantali

  • Severity changed from Normal to Major

comment:2 Changed 10 years ago by Tantali

  • Component changed from Mac Client to Transmission

comment:3 Changed 10 years ago by charles

I'm not able to reproduce this in the GTK+ client.

comment:4 Changed 10 years ago by Tantali

regarding the 'N/A', Transmission does seem to find the file where you put it before it froze, but he simply states in the info-window that he doesn't know the location

comment:5 Changed 10 years ago by Tantali

just tested some other nightlies: r9352 already has the problem r9323 doesn't have the problem

and along with the freeze, the cpu-usage also maxes out...

comment:6 Changed 10 years ago by Tantali

problem originated between the r9341 and the r9351

comment:7 Changed 10 years ago by charles

Tantali: could you test and see if the problem exists in r9343?

comment:8 Changed 10 years ago by Tantali

I would love to, but I don't find a compiled version of that nightly... r9341 and r9351 are the closest I can find on http://transmission.xpjets.com/OLD/2009/10/

And I have no clue how to compile it for myself...

comment:9 Changed 10 years ago by charles

If you wait a few minutes, force quit Transmission and then restart it, only one torrent's data file will be moved. (of the one or more selected torrents)

Do you mean that all the files in on torrent will be moved, or that only one file in the first torrent will be moved?

comment:10 Changed 10 years ago by Tantali

Everything of one torrent will be moved. If you move the data to another drive, it will still remove the data at the original location. So I don't think the problem lies during the moving.

And (in the latest build) it doesn't always seem to find the new location of the data file. Sometimes it still thinks it's at the original location. But in both cases it shows the data location as 'N/A'

comment:11 Changed 10 years ago by livings124

Tantali: could you test and see if the problem exists in r9469?

comment:12 Changed 10 years ago by Tantali

Problem solved! Thx!

comment:13 Changed 10 years ago by livings124

  • Milestone None Set deleted
  • Resolution set to fixed
  • Status changed from new to closed

"volatile" fixed this - closing

comment:14 Changed 9 years ago by exiva

I'd like to reopen this bug. As this appears to be happening again every so often. I am using the latest r9915 and experiencing this issue every so often.

Note: See TracTickets for help on using tickets.