Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2544 closed Bug (fixed)

crash in port fowarding if the evtimer's been deleted

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.77
Component: Transmission Version: 1.76
Severity: Normal Keywords:
Cc:

Description

Downstream: https://bugs.launchpad.net/ubuntu/+source/transmission/+bug/458735

.
Thread 1 (process 4095):
#0  event_add (ev=0x0, tv=0xb767a218) at event.c:721
	base = <value optimized out>
	evsel = (const struct eventop *) 0xb767a218
	evbase = <value optimized out>
	res = 134977270
	__PRETTY_FUNCTION__ = "event_add"
#1  0x080a1cb4 in tr_timerAdd (timer=0x0, seconds=60, milliseconds=0)
    at utils.c:492
	tv = {tv_sec = 60, tv_usec = 0}
#2  0x00d5d248 in event_base_loop (base=0x90c5a80, flags=0) at event.c:392
	evsel = (const struct eventop *) 0xd70eac
	evbase = (void *) 0x90c4360
	tv = {tv_sec = 0, tv_usec = 333000}
	tv_p = <value optimized out>
	res = <value optimized out>

Change History (5)

comment:1 Changed 12 years ago by charles

  • Owner set to charles
  • Status changed from new to assigned

Fixed in trunk for 1.80 by r9441

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 12 years ago by charles

backported to 1.7x in r9875

comment:4 Changed 12 years ago by charles

  • Milestone changed from 1.80 to 1.77

comment:5 Changed 12 years ago by charles

  • Keywords backport-1.7x removed
Note: See TracTickets for help on using tickets.